I deleted the /etc/letsencrypt dir with all its certs


#1

Please fill out the fields below so we can help you better.

My domain is:devops.evolane-ops.be

I ran this command:

It produced this output:

My operating system is (include version):CentOS Linux 7 (Core)

My web server is (include version):nginx/1.6.3
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no


#2

Is there a way to get them back because I did gave my email… Or is it hopeless ? cheers


#3

Hello @GreenEars,

Where are your backups?. You should always create backups for your important stuff ;). Well, you are out of luck, you could recover your cert files due they are sent to CTL (Certificate Transparency Log) but they are useless if you don’t have your private key files.

You could also try to undelete the files with some utility like extundelete if your file system is ext3 or ext4 but it is risky and you have to remount your partition as read-only and that could not be possible in your server, indeed if you want to try it, you have no guarantee that you will recover your files and you could damage your existing file system so, my advice, start over and get new certificates for your domains.

Good luck,
sahsanu


#4

Yes I know that I made a few mistakes :slight_smile: It is a good lesson… For this domain it is over untill they expire i guess ? Or i use another way for creating certs. Thanks for the reply and I’ll remember next time.

Cheers


#5

You can request a new cert for your domain in the same way you did it the first time, doesn’t matter it is not expired, request it again and you’ll get a new one.

Cheers,
sahsanu


#6

Ok I thought It was not possible because i ran the command again but with --keep-until-expiring. Now it is ok :slight_smile:

Thanks for the help and have a great day!


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.