I can't renew the Certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://ce.oclockdt.com

I ran this command: I tried to renew the expired certificate. Virtualmin->Request Certificate

It produced this output: Requesting a certificate for ce.oclockdt.com from Let's Encrypt ..
.. request failed : Web-based validation failed :
Renewing an existing certificate for ce.oclockdt.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log
An unexpected error occurred:
There were too many requests of a given type :: Error creating new order :: too many failed authorizations recently: see Failed Validation Limit - Let's Encrypt
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version): Apache version 2.4.37

The operating system my web server runs on is (include version): Rocky Linux 8.6

My hosting provider, if applicable, is: OVHcloud

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Virtualmin + Webmin

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.22.0

How can I solve this? Please, help me.

that ratelimit takes an hour to expire, so wait a bit
and maybe try webmin's own certificate page?

lookup did for next person
current webpage is running by Virtualmin (landing page on default hostname), it


Unfortunately, the "too many failed authorizations recently" error hides the actual reason why the previous attempts were failing. You should be able to view the actual error in one of the recent log files in /var/log/letsencrypt, i.e., the file just before when the "too many failed authorizations recently" error started to happen.


Well, now I know that Letsencrypt sends a file to the public_html/.well-known/acme-challenge/ folder and I assume that it won't be able to access it. But can you help me to fix this?

Now it appears like this:

1.- I waited an hour.
2.- I retried to obtain the certificate.
3.- The error "Missing file to read at virtual_server::/usr/libexec/webmin/virtual-server/feature-dns.pl line 3529" appeared.
4.- I restarted the server.

Thanks for the suggestions!

1 Like

Your Apache server is still using the old certificate. See a test site like this:


Yes, I'm waiting for LetsEncrypt for that subdomain, thanks.

1 Like

Then why did you mark your post as the Solution? That's used for when the problem is solved.

A successful cert request immediately gets a cert. There is no "waiting" except sometimes requests themselves can take a while to satisfy the challenge.


Sorry, I have 5 virtual servers. I solved for four of them.

1 Like

Do you still want help? If so, which domain name is still not working?


Now all the certificates are working perfectly. Thank you so much.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.