I can't figure out whats the matter

Hello, I already have a reverse proxy working on another server, but is still letsencrypt, this new is swag.
As the other server I followed spaceinvaderone to install it on Unraid, but this time something doesn't work as expected.
If I change in my router the Nat pointing to my unraid UI it works, so subdomain mapping is ok.

Please help me figure it out, thanks U all and have a nice day

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: webaccess.abcpoint.cloud

I ran this command: I just started swag

It produced this output:

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 20-config: executing...
[cont-init.d] 20-config: exited 0.
[cont-init.d] 30-keygen: executing...
using keys found in /config/keys
[cont-init.d] 30-keygen: exited 0.
[cont-init.d] 50-config: executing...
Variables set:
TZ=America/Los_Angeles <<------------ how can I cange this? I'm in Europe, maybe its all about this?

Using Let's Encrypt as the cert provider
SUBDOMAINS entered, processing
SUBDOMAINS entered, processing
Only subdomains, no URL in cert
Sub-domains processed are: -d webaccess.abcpoint.cloud
E-mail address entered: ugo999@gmail.com
http validation is selected
Different validation parameters entered than what was used before. Revoking and deleting existing certificate, and an updated one will be created
Generating new certificate
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Account registered.
Requesting a certificate for webaccess.abcpoint.cloud

Certbot failed to authenticate some domains (authenticator: standalone). The Certificate Authority reported these problems:

Domain: webaccess.abcpoint.cloud
Type: dns
Detail: No valid IP addresses found for webaccess.abcpoint.cloud

Hint: The Certificate Authority failed to download the challenge files from the temporary standalone webserver started by Certbot on port 80. Ensure that the listed domains point to this machine and that it can accept inbound connections from the internet.

Some challenges have failed.

Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.
ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fix your settings and recreate the container

My web server is (include version): i don't know

The operating system my web server runs on is (include version): Unraid

My hosting provider, if applicable, is: Eolo

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): I don't konw/ I'm using default

Hi @ugo999 and welcome to the LE community forum :slight_smile:

This is your biggest problem:

And this might also be an issue:

Name:      abcpoint.cloud

Name:    www.abcpoint.cloud

Thanks for the answer, I figured out that I was NATTED by my ISP :scream:
I solved buying a static IP address for 2 euro/month

I was wrong since the beginning

If I change in my router the Nat pointing to my unraid UI it works, so subdomain mapping is ok.

You made me reconsider and check it so thanks a Lot.

Have a nice day and nice holidays to all this forum. Bye


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.