I can't cert my encrypt

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: ./certbot-auto certonly --webroot -w /opt/bitnami/apps/wordpress/htdocs -d aiofoods.io -d www.aiofoods.io

It produced this output:
Requesting to rerun ./certbot-auto with root privileges…
./certbot-auto has insecure permissions!
To learn how to fix them, visit Certbot-auto deployment best practices
WARNING: unable to check for updates.
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
An unexpected error occurred:
ValueError: Requesting acme-v02.api.letsencrypt.org/directory: Network is unreachable
Please see the logfiles in /var/log/letsencrypt for more details.

My web server is (include version):
AWS lightsail

The operating system my web server runs on is (include version):
AWS lightsail

My hosting provider, if applicable, is:
AWS lightsail

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

If I ran curl acme-v02.api.letsencrypt.org/directory,

I got
curl: (7) Failed to connect to acme-v02.api.letsencrypt.org port 80: Connection timed out

What does
nslookup acme-v02.api.letsencrypt.org

Can you curl to any other web site?
curl https://weather.com/

1 Like

My best guess at this point (without any other info) would be that you have IPv6 enabled but isn’t properly configured or not allowed out.
Guess #2: You have enabled a firewall that is blocking your outbound connections.

1 Like

I Got This

Well it’s not Guess #1.
Guess #2, however, is still in play.
Although DNS works, https access fails.
If you can’t get to any https site (we’ve only tested two)…
Then you need to insure the firewall(s) are allowing it out.

I already opened my AWS lightsail 's firewall, but it doesn’t make any changes…

Are those inbound or outbound settings?
It looks like “accepts” (which only means inbound)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.