Https not working after successful certbot installation


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

www.helgabox.duckdns.org

I ran this command:

sudo certbot --apache

It produced this output:


Congratulations! You have successfully enabled https://helgabox.duckdns.org

You should test your configuration at:
https://www.ssllabs.com/ssltest/analyze.html?d=helgabox.duckdns.org


IMPORTANT NOTES:

  • Congratulations! Your certificate and chain have been saved at:
    /etc/letsencrypt/live/helgabox.duckdns.org/fullchain.pem
    Your key file has been saved at:
    /etc/letsencrypt/live/helgabox.duckdns.org/privkey.pem
    Your cert will expire on 2019-03-19. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot again
    with the “certonly” option. To non-interactively renew all of
    your certificates, run “certbot renew”

  • If you like Certbot, please consider supporting our work by:

    Donating to ISRG / Let’s Encrypt: https://letsencrypt.org/donate
    Donating to EFF: https://eff.org/donate-le

My web server is (include version):

Server version: Apache/2.4.18 (Ubuntu)
Server built: 2018-06-07T19:43:03

The operating system my web server runs on is (include version):

Ubuntu Server 16.04

I can login to a root shell on my machine (yes or no, or I don’t know):

yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

no

Thanks in andvance for your help!


#2

Hi @calgara12,

This looks like a firewall problem, where a host or network firewall isn’t permitting connections on port 443. Can you check that there is no firewall rule anywhere that would block this? (If you’ve set up a router to forward port 80 to some device, you’d also have to set it up to forward port 443 in a similar way.)


#3

Thank you so much. I forgot to forward the port 443.


#4

Hi @calgara12

now your https server works. But you have only a certificate with one domain name:

CN=helgabox.duckdns.org
19.12.2018
19.03.2019
helgabox.duckdns.org - 1 entry

So your www-version doesn’t work.

  • Remove the www - dns entry or
  • Create a new certificate with both domain names - non-www and www

#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.