Https doesn't recognise certificates

I have installed let’s encrypt on centos 6.5 apache 2.2.15 and when I try
I can see that site not taking right certificate, the ones from letsencrypt.
I tried all, checked all but can’t find out what can be wrong that apache configuration is not recognised for server,

DocumentRoot /var/www/html/joomla ServerName ServerAlias ServerPath /var/www/html/joomla Alias /phpmyadmin "/usr/share/phpmyadmin"

Alias /joomla "/var/www/html/joomla"
Alias /roundcube "/usr/share/roundcubemail"
Alias /rcm “/usr/share/roundcubemail”

<Directory “/usr/share/phpmyadmin”>
Options All
AllowOverride All
order allow,deny
allow from localhost 194.X.X.X

<Directory “/var/www/html/mail/cgi-bin”>
Options +ExecCGI

<Directory “/usr/share/roundcubemail”>
Options All
AllowOverride All
order allow,deny
allow from all

<Files ~ “^admin.php”>
Order allow,deny
Allow from 194.X.X.X
Satisfy All

SSLEngine on
SSLCertificateFile /etc/letsencrypt/live/
SSLCertificateKeyFile /etc/letsencrypt/live/
Include /etc/letsencrypt/options-ssl-apache.conf
SSLCertificateChainFile /etc/letsencrypt/live/

Did you restart/reload Apache after obtaining the certificate?

Also, in order for us to help troubleshoot further, you will need to provide your real domain name as stated in the help prompts when you created this post.

yes I did I even restarted server. real domain

Hm, well, you’re currently presenting a self-signed certificate for for some reason… Do you know where that may be coming from?

yes that is from ssl.conf, that was configured before I have installed lets encrypt.
And don’t know why apache doesn’t take settings from joomla.conf which I posted above

Can you post the rest of your config files?

I have installed whole thing from scratch and for now certificates works. I only have trouble with path now for web site.
Apache just can find right path no matter what I put in config file

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.