Http:// would not load after installed

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: mehome.com.au

I ran this command: I followed all instruction here. https://certbot.eff.org/lets-encrypt/centosrhel7-nginx

It produced this output:

My web server is (include version):nginx

The operating system my web server runs on is (include version):centos7

My hosting provider, if applicable, is: vultr.com

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): I use putty and panel bt(chinese version)

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
Traceback (most recent call last):
Traceback (most recent call last):
File “/usr/bin/certbot”, line 5, in
from pkg_resources import load_entry_point
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 3250, in
@_call_aside
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 3234, in _call_aside
f(*args, **kwargs)
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 3263, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 585, in _build_master
return cls._build_from_requirements(requires)
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 598, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File “/usr/lib/python2.7/site-packages/pkg_resources/init.py”, line 791, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (cryptography 2.1 (/usr/lib64/python2.7/site-packages), Requirement.parse(‘cryptography>=2.3’), set([‘PyOpenSSL’]))

1 Like

Hi @alexzho

your cryptography package is too old. So check if there is an update.

PS: Perhaps with

pip install cryptography --upgrade
1 Like

@bmw, is there any indication that our CentOS instructions are out of date?

@alexzho, did you install any packages manually using pip on this system?

@JuergenAuer, this may fix the problem in this case, but the ContextualVersionConflict error is usually reflective of a conflict in how different parts of one’s Python environment were installed (e.g. some via apt or yum and some via pip). So it may be better to ensure that Python packages are only being managed via one package management method, or make sure that all of our documentation is up-to-date here.

2 Likes

No. The version of cryptography available in CentOS 7 is 1.7.2. The package can be seen at http://mirror.centos.org/centos/7/os/x86_64/Packages/python2-cryptography-1.7.2-2.el7.x86_64.rpm.

The version of pyOpenSSL available in CentOS 7 is 0.13. The package can be seen at http://mirror.centos.org/centos/7/os/x86_64/Packages/pyOpenSSL-0.13.1-4.el7.x86_64.rpm. This package doesn’t even depend on cryptography.

# yum deplist pyopenssl
Loaded plugins: fastestmirror, ovl
Loading mirror speeds from cached hostfile
 * base: mirror.sjc02.svwh.net
 * epel: mirror.prgmr.com
 * extras: mirror.sjc02.svwh.net
 * updates: mirrors.ocf.berkeley.edu
package: pyOpenSSL.x86_64 0.13.1-4.el7
  dependency: libc.so.6(GLIBC_2.14)(64bit)
   provider: glibc.x86_64 2.17-260.el7_6.6
  dependency: libcrypto.so.10()(64bit)
   provider: openssl-libs.x86_64 1:1.0.2k-16.el7_6.1
  dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
   provider: openssl-libs.x86_64 1:1.0.2k-16.el7_6.1
  dependency: libcrypto.so.10(libcrypto.so.10)(64bit)
   provider: openssl-libs.x86_64 1:1.0.2k-16.el7_6.1
  dependency: libpthread.so.0()(64bit)
   provider: glibc.x86_64 2.17-260.el7_6.6
  dependency: libpython2.7.so.1.0()(64bit)
   provider: python-libs.x86_64 2.7.5-80.el7_6
  dependency: libssl.so.10()(64bit)
   provider: openssl-libs.x86_64 1:1.0.2k-16.el7_6.1
  dependency: libssl.so.10(libssl.so.10)(64bit)
   provider: openssl-libs.x86_64 1:1.0.2k-16.el7_6.1
  dependency: python(abi) = 2.7
   provider: python.x86_64 2.7.5-80.el7_6
  dependency: rtld(GNU_HASH)
   provider: glibc.x86_64 2.17-260.el7_6.6
   provider: glibc.i686 2.17-260.el7_6.6

I think the problem here is there being a pyOpenSSL package installed from another source like pip. pip and OS package managers do not play well together.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.