How to recover my site


#1

How do i remove redirect to https from the new instance server that i have? or how do i get my certificates from the previous instance server?


#2

Can you tell us what server you use (Apache or Nginx)? You’ll want to look in your configuration, under /etc/, to find the lines that do the redirect, then remove those and restart your server.


#3

Thanks for reply, Am using Apache and the thing is i had configured letsencrypt on an aws instance which it never worked, i also enabled redirect my domain to listen https. so i deleted that instance, i am using another instance in which it forces the domain to redirect to https while i have no certificate again on my new instance server.


#4

How is it being forced?


#5

I have allowed it redirect to https.


#6

If you have a redirect configured somewhere in Apache, you may be able to identify its location using:

grep -RFin "RewriteCond %{HTTPS}" /etc/{apache2,apache,httpd}

It would be really helpful to know what your domain is, it would provide valuable information about how the redirect might be implemented.


#7

Thanks, but am on new instance server which i have to start afresh installing certbot.


#8

My site is pagesmade.com


#9

Hi @pmade

your domain is completely invisible ( https://check-your-website.server-daten.de/?q=pagesmade.com ):

Domainname Http-Status redirect Sec. G
http://pagesmade.com/
13.126.16.32 -14 10.030 T
Timeout - The operation has timed out
http://www.pagesmade.com/
13.126.16.32 -14 10.026 T
Timeout - The operation has timed out
https://pagesmade.com/
13.126.16.32 -14 10.023 T
Timeout - The operation has timed out
https://www.pagesmade.com/
13.126.16.32 -14 10.027 T
Timeout - The operation has timed out
http://pagesmade.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
13.126.16.32 -14 10.027 T
Timeout - The operation has timed out
http://www.pagesmade.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
13.126.16.32 -14 10.027 T
Timeout - The operation has timed out

Only timeouts, nothing else. No redirect is visible.

Start your http, then use http - 01 validation.

You have one certificate created

https://transparencyreport.google.com/https/certificates?cert_search_auth=&cert_search_cert=&cert_search=include_expired:false;include_subdomains:false;domain:pagesmade.com&lu=cert_search

So it’s not a critical problem with the rate limit. Create one new certificate.


#10

so i fixed it but still i cant get the https, though i got the congratulation message.
Using:
AWS ubuntu 18.04
site pagesmade.com
Apache server

i only get http


#11

You have a new certificate

https://transparencyreport.google.com/https/certificates?cert_search_auth=&cert_search_cert=&cert_search=include_expired:false;include_subdomains:false;domain:pagesmade.com&lu=cert_search

with two domain names (www + non-www), this is good.

Your http works, your https is blocked ( https://check-your-website.server-daten.de/?q=pagesmade.com ):


Domainname Http-Status redirect Sec. G
http://pagesmade.com/
13.126.192.195 200 0.270 H
http://pagesmade.com/
52.66.95.210 200 0.304 H
http://www.pagesmade.com/
13.126.192.195 200 0.270 H
http://www.pagesmade.com/
52.66.95.210 200 0.310 H
https://pagesmade.com/
13.126.192.195 -2 1.397 V
ConnectFailure - Unable to connect to the remote server No connection could be made because the target machine actively refused it 13.126.192.195:443
https://pagesmade.com/
52.66.95.210 -2 1.400 V
ConnectFailure - Unable to connect to the remote server No connection could be made because the target machine actively refused it 52.66.95.210:443
https://www.pagesmade.com/
13.126.192.195 -2 1.396 V
ConnectFailure - Unable to connect to the remote server No connection could be made because the target machine actively refused it 13.126.192.195:443
https://www.pagesmade.com/
52.66.95.210 -2 1.390 V
ConnectFailure - Unable to connect to the remote server No connection could be made because the target machine actively refused it 52.66.95.210:443

Is there a firewall or something else?


#12

on my ufw i allowed Apache Full

i followed this instructions on setting the site https://www.digitalocean.com/community/tutorials/how-to-secure-apache-with-let-s-encrypt-on-ubuntu-18-04


#13

HTTPS connections are currently being refused:

Connecting to www.pagesmade.com (www.pagesmade.com)|13.126.192.195|:443… failed: Connection refused.
Connecting to www.pagesmade.com (www.pagesmade.com)|52.66.95.210|:443… failed: Connection refused.

Connecting to pagesmade.com (pagesmade.com)|52.66.95.210|:443… failed: Connection refused.
Connecting to pagesmade.com (pagesmade.com)|13.126.192.195|:443… failed: Connection refused.


#14

i cant understand also, is the problem due to aws or? my firewall is Apache Full allowed.


#15

“Connection refused” usually means that the firewall is allowing traffic, but there isn’t any web server running on that IP and port.


#16

so will it be the aws issue?


#17

It’s impossible to say.


#18

or is the installation procedure in https://www.digitalocean.com/community/tutorials/how-to-secure-apache-with-let-s-encrypt-on-ubuntu-18-04 lack something?


#19

Can you show what is running?
netstat -pant


#20

(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.53:53 0.0.0.0:* LISTEN -
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN -
tcp 0 684 172.31.5.29:22 41.220.129.226:36116 ESTABLISHED -
tcp6 0 0 :::443 :::* LISTEN -
tcp6 0 0 :::80 :::* LISTEN -
tcp6 0 0 :::22 :::* LISTEN -
tcp6 0 0 172.31.5.29:80 172.31.16.154:40732 TIME_WAIT -
tcp6 0 0 172.31.5.29:80 172.31.16.154:40726 TIME_WAIT -