How to re-authorize a domain under "urn:acme:error:rateLimited"


#1

Dear all,

Im trying to validate my domain hosted in Kubernetes
Found out that my kube-lego was throwing errors like:

time="2018-03-19T06:58:26Z" level=warning msg="authorization failed after 1m0s: getting authorization failed: 429 urn:acme:error:rateLimited: Error creating new authz :: too many failed authorizations recently: see https://letsencrypt.org/docs/rate-limits/" context=acme domain=rest.lalamove.com

After checking the documents, there should be a rate limit with 5/hours failures.
I stopped the request over the weekend and tried again, it still throwing the same error.

My logs didnt include any logs like https://acme-v01.api.letsencrypt.org/acme/authz/XYZ, so i could not trigger an validation attempt.

May I know if there any way to get rid of this stage and re-authorize without waiting a whole week?
Please advise.


#2

Hi,

Can you please share us your domain name? (Just trying to make sure you are using your own domain name, not a shared or being shared )

Also, I’m checking the docs and found that Lego is in maintenance mode only.
Can you try to use https://github.com/jetstack/cert-manager/ instead?

Thank you


#3

my domain name is rest.lalamove.com

thanks for helping :slight_smile:


#4

The rate limit is 5 per hour. Unless there’s a server bug, it must not have actually stopped.

Can you watch the logs or tcpdump or something for a while to see if it’s still going?


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.