How to https://domain.tld to https://www.domain.tld


#1

Hello,
I am using virtualmin 5.0 gpl on my centos6.8 vps. i installed the Letsencrypt using Virtualmin integrated feature.
Please note:- Due to new user restrictioni have given a space between following site example)
Its working very well but only the problem is my site using https: // domain. tld not a https: // www.domain. tld
If i am trying to use https: // domain. tld work well, but with https: // www.domain. tld, Bad cert error.

www. domain. tld uses an invalid security certificate. The certificate is only valid for domain. tld
Error code: SSL_ERROR_BAD_CERT_DOMAIN

Please help me to correct this.

Regards


#2

When you create the cert, you need to include every hostname you want to use on the cert. So in your case, you’d need to request the cert for both domain.tld and www.domain.tld.


#3

Thanks dan, there is a some config issue, i am re-installing my vps, i will try your option.
But i want to inform you, its a inbuilt option of virtualmin, where i can request for certificate from virtualmin CP.

Thanks


#4

After completin of all vps setup, i am trying to request for certificate getting a following error.
Failed to request certificate :

Parsing account key…
Parsing CSR…
Registering account…
Registered!
Verifying softonsolutions.in
softonsolutions.in verified!
Signing certificate…
Traceback (most recent call last):
File "/usr/libexec/webmin/webmin/acme_tiny.py", line 203, in <module>
main(sys.argv[1:])
File "/usr/libexec/webmin/webmin/acme_tiny.py", line 199, in main
signed_crt = get_crt(args.account_key, args.csr, args.acme_dir, log=LOGGER, CA=args.ca)
File "/usr/libexec/webmin/webmin/acme_tiny.py", line 166, in get_crt
raise ValueError("Error signing certificate: {0} {1}".format(code, result))
ValueError: Error signing certificate: 429 {
"type": "urn:acme:error:rateLimited",
"detail": "Error creating new cert :: Too many certificates already issued for exact set of domains: softonsolutions.in",
"status": 429
}
What is the solution for this ?

#5

I think your issue is there, ard. You might have to wait the week - check out the rate limits at https://letsencrypt.org/docs/rate-limits/ (I think you triggered Certificates/FQDNset limit).


#6

Thanks kiint & danb,
Problem is solved, i tried with my other domain, its working, the issue was with update, i was using virtualmin5.0 gpl, which don’t have a option Domains name listing or Domains associated with this server.
After updating to Virtualmin 5.0.5gpl, i got the option.

Thanks for your help…