How to enable HTTPS / TLS support on my server speedtest on ubuntu 18-04LTS

#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: speedtest.skyvisiongn.com

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Speedserver sur le site ookla
#2

Hi @lebasto7,

Are you the administrator of this server, and do you have root access to it? What kind of web server software does this server run?

#3

yes I am administrator I access by root and the web server is appache operating system is ubuntu 18.04 LTS

#4

Hi @lebasto7

then you should be able to create a certificate.

First read the basics:

Then select a client:

Perhaps Certbot should work:

#5

please you can send the procedure because I tried it does not work and there is even my server of speedtest which is not functional I had to resume all

#6

Then please answer the questions of the template: Your command, the output.

I can’t find a certificate.

https://crt.sh/?q=speedtest.skyvisiongn.com

Your site uses a self signed certificate ( https://check-your-website.server-daten.de/?q=speedtest.skyvisiongn.com ):

CN=ubuntu
	04.08.2018
	01.08.2028
expires in 3438 days	ubuntu - 1 entry

But your main configuration is ok:

Domainname Http-Status redirect Sec. G
http://speedtest.skyvisiongn.com/
160.119.131.14 200 0.210 H
https://speedtest.skyvisiongn.com/
160.119.131.14 200 5.993 N
Certificate error: RemoteCertificateNameMismatch, RemoteCertificateChainErrors
http://speedtest.skyvisiongn.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
160.119.131.14 404 0.214 A
Not Found
Visible Content: Not Found The requested URL /.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de was not found on this server. Apache/2.4.29 (Ubuntu) Server at speedtest.skyvisiongn.com Port 80

Port 80 is open, no wrong redirects, /.well-known/acme-challenge answers with a (correct) http status 404 - Not Found, if the file is unknown.

So

certbot run -a webroot -i apache -w yourDocumentRoot -d speedtest.skyvisiongn.com

should work if you use Certbot.

#7

Perhaps that thread may help:

Another speedtest - user.

closed #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.