How do clear a pending authorization from command line?

I stupidly tried to get certs for all my websites using Certbot and now I have hit the authoization limit.

I’m not that experienced at sysadmin so although I vaguely understand the docs on “Responding To Challenges” I can’t really figure out what exactly goes in each field and how to send the request.

I’ve tried using Curl but it returns “malformed”

Any help much appreciated!

There is a tool called acmecancel:

You’ll need to have the authz identifier from a client log and also an account key in a file format that acmecancel expects.

1 Like

Thank you.

Where do I find out “X” “Y” and “D”?

I’ve never used acmecancel; maybe we could ask @voutasaurus for help.

If you’re talking about the elliptic curve private key parameters, it depends on what ACME client you used before; if it was Certbot, you should look in /etc/letsencrypt/accounts for the account key.

I use a custom client so I’m looking at the format of /etc/letsencrypt/accounts/acme-v01.api.letsencrypt.org/directory/XXXX/private_key.json for the first time here. Mine looks like it’s RSA. acmecancel currently only supports ECDSA registration keys.

Let me know if you have an ECDSA key or an RSA key.

Hi @SebTucknott,

As you are using certbot, you could take a look to this post to invalidate those pending authzs Too many requests of a given type - how do you reset this?

Also, keep in mind that Let’s Encrypt allows “only” 100 domains/subdomains per certificate.

Good luck,
sahsanu

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.