Hostname/IP does not match certificate’s altnames

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: Issue SSL certificate from Cyberpanel console

It produced this output:
Hostname/IP does not match certificate's altnames: Host: is not in the cert's altnames:,

My web server is (include version): LiteSpeed Web Server (Cyberpanel)

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Cyberpanel

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): No idea

Hope you can help me with this one. All was working fine with this site until I had to delete it and reinstall it, something weird happened when I issued the certificate. That other site is also mine, it was installed in the same server, I already deleted to test what happened, but it keeps showing this.
Also when I try to issue the certificate from Cyberpanel the command freezes. I checked logs nothing there. Then I run this command
/root/ --issue -d -d --cert-file /etc/letsencrypt/live/ --key-file /etc/letsencrypt/live/ --fullchain-file /etc/letsencrypt/live/ -w /home/ --server letsencrypt --force --debug --log

It seemed worked fine

Many Thanks,

My operating System is Ubuntu 20.4.

Your server configuration is loading the certificate for instead which suggests that your webserver configuration needs to be adjusted to use the appropriate server for your domain.

You will want to avoid the use of that flag. It results in unexpected complications far more often than it solves the problem the user hoped to remedy by adding it to the command.


Good to know, thanks.

1 Like

Cyberpanel has some Community resources pertaining to Let's Encrypt. They don't appear to use Certbot, though. I don't know if their documentation will help you figure out why the wrong certificate is being used by your site, but it can't hurt to examine.


Thanks linkp! I already went there :slight_smile:


How did you delete it?
It seem it was not a 100% clean delete of the site; maybe only the web content.

1 Like

Hi Bruce, I deleted from Cyberpanel, delete website option, I'm sure this deletes everything. :slight_smile:

1 Like

I would check on their forum for how their deletion works.

1 Like

How did you come up with this command? Because it looks like you're using the ACME client to install certificates into the location commonly used by the ACME client Certbot. Which is kinda weird to me. Did you use some kind of online guide?


Yes I did, don't worry it has been solved. Thank you all for your help.


Could you please tell us how you fixed your issue for future readers of this thread?


Hi Osiris, I was able to delete everything related to the other site in my server, Many Thanks.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.