Hostinger Domain, Litespeed Server - Unauthorized Errors

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: certbot certonly --webroot -w /usr/local/lsws/Example/html -d -d

It produced this output:

Requesting a certificate for and

Certbot failed to authenticate some domains (authenticator: webroot). The Certificate Authority reported these problems:
Type: unauthorized
Detail: 2a02:4780:b:1267:0:3936:53f4:2: Invalid response from 404

Type: unauthorized
Detail: Invalid response from 404

Hint: The Certificate Authority failed to download the temporary challenge files created by Certbot. Ensure that the listed domains serve their content from the provided --webroot-path/-w and that files created there can be downloaded from the internet.

Some challenges have failed.
The log is attached.
letsencrypt.txt (26.3 KB)

My web server is (include version): LiteSpeed

The operating system my web server runs on is (include version): Ubuntu 22.04 64bit with Node.js, using a template provided by LiteSpeedTech that is documented here.

My hosting provider, if applicable, is: Hostinger

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): OpenLiteSpeed

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 2.7.4

Some extra info:

I have been hammering at this problem for two straight days, adjusting a million things to no avail. /usr/local/lsws/Example/html/.well-known/acme-challenge is the filepath we have been using when trying out a test file. When we try to access the test file via it doesn't show the file, only some node code that's live on the server. If I remove that example litespeed code, all we get are 404s for the testfile.

  • We have checked there are no firewall rules

  • We have checked the domain points to the correct IP address for this server

  • We have tried killing all listeners and virtual hosts and trying the certbot

  • We also tried routing through the path var/www/html with the same results

Hi @baileygocode, and welcome to the LE community forum :slight_smile:

I believe that LiteSpeed is based on Apache.
If so, I'd check to be sure there are no [name:port] overlaps.


I would say the server is not responding the same for IPv4 and IPv6.


Two names, two IPs:


Yes, one with both IPv4 and v6 and one with just IPv4 0 IN A 0 IN AAAA 2a02:4780:b:1267:0:3936:53f4:2 0 IN A

Sorry y'all I'm really new to this kind of stuff - does that mean there's an issue with how my server is set up?

Several [issues].


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.