Hi, When i renewed SSL certificate in aws bitnami it is showing error Could not create client: get directory at 'https://acme-v02.api.letsencrypt.org/directory': Get "https://acme-v02.api.letsencrypt.org/directory": x509: certificate signed by unknown aut

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: jnanoworld.com

I ran this command: sudo /opt/bitnami/letsencrypt/lego --tls --email="XXXX" --domains="XXX" --path="/opt/bitnami/letsencrypt" renew

It produced this output: Could not create client: get directory at 'https://acme-v02.api.letsencrypt.org/directory': Get "https://acme-v02.api.letsencrypt.org/directory": x509: certificate signed by unknown authority

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don't know): I don't know

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): putty

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): lego latest version : 4.5.2

1 Like

Hi @snvs welcome to the LE community forum :slight_smile:

It seems that your systems' certificates haven't been updated lately.
Please show the output of:
apt install ca-certificates

2 Likes

Hi Thanks for reply.

After run this command apt install ca-certificates. I tried to renew ssl certificate this time showing error like this. Could not obtain certificates:
error: one or more domains had a problem:
[domain.com] acme: error: 400 :: urn:ietf:params:acme:error:connection :: Timeout during connect (likely firewall problem)

2 Likes

Did the command update anything?
[you didn't show the output...]

Try also:
update-ca-certificates

1 Like

Yes updated. Now SSL certificate also working. Thank you so much

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.