Help certificates at windows server 2012 (jws has invalid anti-replay nonce)


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: http://test1.schoolbooks.kro.kr/

I ran this command: letsencrypt-win-simple.v1.9.7.0 exe program
I tried the following :

  1. “N” (create new certificate)
  2. “4” (Manually input host names)
  3. test1.schoolbooks.kro.kr (Enter host names, separate comma …)
  4. “6” (Upload verification file to WebDav path)
  5. “Y” (Copy default web.config …)
  6. http://test1.schoolbooks.kro.kr/ (Enter the web root of the host for http authentication)

I put the “:” character at the end of the 6th, and 80port was also described.
but it’s not work, and error occurred.

It produced this output:
jws has invalid anti-replay nonce …

My web server is (include version): Apache httpd 2.4

The operating system my web server runs on is (include version): Windows Server 2012 R2 Standard

My hosting provider, if applicable, is: I do not understand what it usually this sentance means

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#2

From https://github.com/PKISharp/win-acme/issues/653#issuecomment-348562083 ,

First one: “JWS has invalid anti-replay nonce” - this happens when you spend too much time in the main menu. There seems to be some kind of timeout period where the client is supposed to refresh the nonce but doesn’t. I believe this is fixed in 1.9.8.

If that doesn’t help, consider opening an issue on their project.


#3

thanks _az, certainly the error described above does not happen again.


#4

_az’s answer was helpful.

In case you are looking for someone with this problem, write down below.

different error occurred.
the error message is “Error uploading file (domain.com.well-known\acme\challenge\asdasd5E2…)
wrong URI : URI is Empty”

[EROR] Authorization result: invalid
[EROR] Error authorizing [Manual] [1 binding - test1.schoolbooks.kro.kr @ \test1.schoolbooks.kro.kr:80]
[EROR] NullReferenceException: Object reference not set to an instance of an object.
[EROR] Create certificate failed


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.