Help! certificate is not installed!

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:tehcxweb.com

I ran this command:
sudo /usr/local/bin/certbot --apache --agree-tos --redirect --hsts --staple-ocsp --email tav@tehcxweb.xyz -d mail.tehcxweb.xyz
It produced this output:
Complete!
Creating virtual environment…
Installing Python packages…
Installation succeeded.
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Error while running apachectl configtest.

AH00526: Syntax error on line 85 of /etc/httpd/conf.d/ssl.conf:
SSLCertificateFile: file ‘/etc/pki/tls/certs/localhost.crt’ does not exist or is empty

The apache plugin is not working; there may be problems with your existing configuration.
The error was: MisconfigurationError(“Error while running apachectl configtest.\n\nAH00526: Syntax error on line 85 of /etc/httpd/conf.d/ssl.conf:\nSSLCertificateFile: file ‘/etc/pki/tls/certs/localhost.crt’ does not exist or is empty\n”,)
[tav@mail ~]$ sudo systemctl reload httpd
Job for httpd.service failed because the control process exited with error code.
See “systemctl status httpd.service” and “journalctl -xe” for details.
My web server is (include version):Apache/2.4.37 (centos)

The operating system my web server runs on is (include version):
CentOS 8.1
My hosting provider, if applicable, is:reg.ru

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):certbot 1.3.0

after errors apache also fails to start
Apache in default configuration
mail.tehcxweb.xyz.conf :
<VirtualHost *:80>
\ ServerName mail.tehcxweb.xyz

\ DocumentRoot /var/www/html/
</VirtualHost>

I’m just starting to learn CentOS help me figure it out

1 Like

I Dobryy den’!!! problema !!! Nedavno ustanovlennyy CentOS 8 ne ustanavlivayet sertifikaty. Mne nuzhny sertifikaty dlya moyego pochtovogo servera. Konfiguratsiya Apache po umolchaniyu
config mail.tehcxweb.xyz.conf:

\ <VirtualHost *: 80>
\ ServerName mail.tehcxweb.xyz

\ DocumentRoot / var / www / html /
\ </ VirtualHost>

YA ispol’zuyu komandu dlya zapuska:
sudo firewall-cmd --zone = public --permanent --add-service = {http, https, prosmotr smtp, smtps, imap, imaps}
sudo systemctl perezagruzit’ firewald
sudo dnf ustanovit’ wget
sudo wget https://dl.eff.org/certbot-auto
sudo mv certbot-auto / usr / local / bin / certbot
sudo chown root / usr / local / bin / certbot
sudo chmod 0755 / usr / local / bin / certbot
sudo / usr / local / bin / certbot --apache --agree-tos --redirect --hsts --staple-ocsp --email tav@tehcxweb.xyz -d mail.tehcxweb.xyz

YA poluchayu oshibku:
Complete!
Sozdaniye virtual’noy sredy …
Ustanovka paketov Python …
Ustanovka proshla uspeshno.
Sokhraneniye zhurnala otladki v /var/log/letsencrypt/letsencrypt.log
Oshibka zapuska apachectl configtest.

AH00526: Sintaksicheskaya oshibka v stroke 85 fayla /etc/httpd/conf.d/ssl.conf:
SSLCertificateFile: fayl ‘/etc/pki/tls/certs/localhost.crt’ ne sushchestvuyet ili yavlyayetsya pustym

Plagin apache ne rabotayet; mogut byt’ problemy s vashey sushchestvuyushchey konfiguratsiyey.
Oshibka: MisconfigurationError («Oshibka zapuska apachectl configtest. \ N \ nAH00526: Sintaksicheskaya oshibka v stroke 85 fayla /etc/httpd/conf.d/ssl.conf:\nSSLCertificateFile: fayl '/ etc / pki / tls / certs / localhost. crt 'ne sushchestvuyet ili yavlyayetsya pustym \ n ",)

i Apache blagopoluchno umirayet
v rezul’tate ni Apache, ni sertifikat
chto mne delat’?
Развернуть
1665/5000
Good afternoon!!! problem !!! The recently installed CentOS 8 does not install certificates. I need certificates for my mail server. Apache default configuration
config mail.tehcxweb.xyz.conf:

\ <VirtualHost *: 80>
\ ServerName mail.tehcxweb.xyz

\ DocumentRoot / var / www / html /
\ </ VirtualHost>

I use the command to run:
sudo firewall-cmd --zone = public --permanent --add-service = {http, https, view smtp, smtps, imap, imaps}
sudo systemctl reload firewald
sudo dnf install wget
sudo wget https://dl.eff.org/certbot-auto
sudo mv certbot-auto / usr / local / bin / certbot
sudo chown root / usr / local / bin / certbot
sudo chmod 0755 / usr / local / bin / certbot

after starting the installation of certificates
Apache dies safely
as a result neither Apache nor certificate
what should I do?

Hi @Ice_walker

looks like you have deleted your certificate.

So disable the port 443 vHost and check your domain, so only port 80 is running.

PS: There

and there

are two different topics, 6 and 3 days old with the same domain name.

So you have deleted folders, so you know what you have to do.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.