Had a problem while installing Python packages

My domain is: famsd.duckdns.org

I ran this command: ./letsencrypt-auto --help all or any other… like certbot or certbot-auto

It produced this output:
Collecting certbot-nginx==0.33.1 (from -r /tmp/tmp.pmi2k1L4tq/letsencrypt-auto-requirements.txt (line 213))
Downloading https://files.pythonhosted.org/packages/6f/4a/5f8d4c6d36db2281c38f7aa6e0c4c4693329afb58fc661ae6c6e7195ace5/certbot_nginx-0.33.1-py2.py3-none-any.whl (86kB)
Requirement already satisfied: setuptools>=1.0 in /opt/eff.org/certbot/venv/lib/python2.7/site-packages (from josepy==1.1.0->-r /tmp/tmp.pmi2k1L4tq/letsencrypt-auto-requirements.txt (line 87))
THESE PACKAGES DO NOT MATCH THE HASHES FROM THE REQUIREMENTS FILE. If you have updated the package versions, please update the hashes. Otherwise, examine the package contents carefully; someone may have tampered with them.
pycparser==2.19 from https://www.piwheels.org/simple/pycparser/pycparser-2.19-py2.py3-none-any.whl#sha256=344870c533812cb119c5475b5aed033ec546118711338ff9b2b78e67098d64e7 (from -r /tmp/tmp.pmi2k1L4tq/letsencrypt-auto-requirements.txt (line 105)):
Expected sha256 a988718abfad80b6b157acce7bf130a30876d27603738ac39f140993246b25b3
Got 344870c533812cb119c5475b5aed033ec546118711338ff9b2b78e67098d64e7

My web server is (include version):

The operating system my web server runs on is (include version): Rasbian

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.28.0

Hi @sercio

that’s a general problem.

Please read

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.