Letsencrypt-auto routine abort with follow log

#1

My domain is:myfritz.net

I ran this command:sudo ./letsencrypt-auto

It produced this output:

Requirement already satisfied: setuptools>=1.0 in /opt/eff.org/certbot/venv/lib/python2.7/site-packages (from josepy==1.1.0->-r /tmp/tmp.F7DwapMySR/letsencrypt-auto-requirements.txt (line 87))THESE PACKAGES DO NOT MATCH THE HASHES FROM THE REQUIREMENTS FILE. If you have updated the package versions, please update the hashes. Otherwise, examine the package contents carefully; someone may have tampered with them. pycparser==2.19 from https://www.piwheels.org/simple/pycparser/pycparser-2.19-py2.py3-none-any.whl#sha256=344870c533812cb119c5475b5aed033ec546118711338ff9b2b78e67098d64e7 (from -r /tmp/tmp.F7DwapMySR/letsencrypt-auto-requirements.txt (line 105)): Expected sha256 a988718abfad80b6b157acce7bf130a30876d27603738ac39f140993246b25b3 Got 344870c533812cb119c5475b5aed033ec546118711338ff9b2b78e67098d64e7

Certbot has problem setting up the virtual environment.We were not be able to guess the right solution from your pipoutput.Consult https://certbot.eff.org/docs/install.html#problems-with-python-virtual-environmentfor possible solutions.You may also find some support resources at https://certbot.eff.org/support/

My web server is (include version): Apache/2.4.25 (Raspbian)

The operating system my web server runs on is (include version): Raspbian Stretch Lite Version: April 2019

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

#2

Hi @Kenarso

there are some topics with the same error message.

Please check