Got an Email from letsencrypt to Renewal the certificates

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: le-39213741.prod.mexicoinsuranceonline.com
mexico-quote.mexpro.com
nfp-cross-border-pgr-polmaker-tmp.prod.mexicoinsuranceonline.com
polmaker-v3.mexicoinsuranceonline.com
sb.iigins.com
v3.app.polmaker.com

I ran this command: N/A

It produced this output: N/A

My web server is (include version): N/A

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): No

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Hi @ChicoAmante and welcome to the forum!

Your certs are coming from the "Let's Encrypt Staging Server"
You will need to use the "production server" to acquire your certs that will work for you.
Will you share the command used to obtain the certs? I am relatively certain it will reveal the issue and help us resolve this problem quickly.
Hope this helps.

4 Likes

I tried this command- kubectl describe certificates -n cert-manager but its throwing an error like no namespace

tried this command -- kubectl get certificate --all-namespaces

got the below output

NAMESPACE NAME READY SECRET AGE
mailgun-proxy-14615397 production-auto-deploy-tls True production-auto-deploy-tls 76d
mexpro-13549566 production-auto-deploy-tls True production-auto-deploy-tls 76d
polmaker-v3-13549425 production-auto-deploy-tls True production-auto-deploy-tls 76d
redirect-catchall-13780976 production-auto-deploy-tls True production-auto-deploy-tls 76d

When i described the certificate

got the below output:

OK thanks.. I dont use kubernetes and am not familiar with it's functions. AN expert volunteer here may be able to help you. I found this with a quick search...

Hope this helps.

4 Likes

You may need to reread that email.

4 Likes

@ChicoAmante

I am able to help you with k8s and cert-manager, but I suggest that you read this first:

Make certain that you are using production certificates per @Rip's observation about your erroneously using staging certificates.

4 Likes