Getting a certificate for the first time

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: kofc6139.org

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: cPanel / GoDaddy

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): 78.0 (build 38)

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Is there a question, or a specific LE related problem, in there that I missed?
All I see is the title “Getting a certificate for the first time”
…
So congrats!?! You’ve decided on getting a certificate and this is your first time.
“I’ll alert the media.”
-Hobson [Arthur (1981 film)]

That said, the site already responds to HTTPS.
So you may need to review those settings - or if it is on a shared hosting environment, you may need to speak with your hosting provider directly on how to secure your web site within their system.

Not sure how it responds to https… it is an unsecure site and is why I am trying to acquire a certificate.

image

Try:
httpS://kofc6139.org/
I get:


and after “continuing”:

So you’re in good hands…
They are already planning “something quite cool” for you… - ROFL

That is HTTPS.
That is (already being) done by whomever runs that server.
You need to speak with your…
Wait… I think I’m repeating myself.
Go back and read my post.

I have read it a few times… there are no certs on this site and is why I am trying to get one from Let’s encrypt

You NEED to speak to whomever runs the site; It already has HTTPS.
LE can’t override their control (nor settings).

I run the site… I can install a cert through the cPanel UI. I got from the get started doc’s that I can get a cert from LE but I would have to install it manually. What am I missing?

If you have cPanel, don’t use LE (use only cPanel for certs).
Mixing them will only create WORLD CHAOS - oh wait, that’s already happening.
You may have to update cPanel to support LE certs (properly) natively; but that is the right way to go.

Ok - thanks for the direction… and once cPanel can use LE, what are the next steps?

Everything would be “menu driven” (in cPanel).
Point, click, relax.

10-4 - I will give it a shot! Thanks again…

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.