Getting 404 errors when trying to renew/install certificate


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
creativity-showcase.com
I ran this command:
certbot-auto certonly --nginx -w /var/www -d creativity-showcase.com -d www.creativity-showcase.com

It produced this output:
“\r\n404 Not Found\r\n<body
bgcolor=“white”>\r\n

404 Not
Found

\r\n

My web server is (include version):
nginx 1.10.3
The operating system my web server runs on is (include version):
Ubuntu 16.04.3 LTS
My hosting provider, if applicable, is:
Oracle
I can login to a root shell on my machine (yes or no, or I don’t know):
Yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
No

Additional info:

I can access files in the .well-known/acme-challenge directory:

http://creativity-showcase.com/.well-known/acme-challenge/aa

I have no IPV6 dns address:
curl -ikL6 http://creativity-showcase.com/.well-known/acme-challenge/aa
curl: (6) Could not resolve host: creativity-showcase.com

The site is hosting a wordpress install. The relevant nginx config :

location ^~/.well-known {
try_files $uri =404;
}

What else can i check to find the problem?


#2

It worked without problems using getSSL… I changed nothing but the getSSL config


#3

Hi @dashiad

-w alone doesn’t work, the --webroot parameter is missing. Use something like

certbot-auto certonly -a webroot -w /var/www -d creativity-showcase.com -d www.creativity-showcase.com

If you use certonly and webroot, you don’t need the --nginx - parameter.