Fullchain.pem error ¡¡my websites are down!

Hi, I have installed my certificate without problems following these steps:

When I have given ngix restart: ’ sudo service nginx-sp start '
I get this error:

Starting nginx-sp: nginx: [emerg] BIO_new_file("/etc/letsencrypt/live/ayeryhoy/fullchain.pem") failed (SSL: error:02001002:system library:fopen:No such file ordirectory:fopen(’/etc/letsencrypt/live/ayeryhoy/fullchain.pem’,‘r’) error:2006D0 80:BIO routines:BIO_new_file:no such file)

I checked that file and if it exists. In that file I find two blocks of text with “Begin Certificate” and End Certificate "

From that moment all my websites that I have installed in Serverpilot are down !!!

Please can you help me?
Thank you

Check the file ownership.
Ensure nginx program/user can read it.

I’m very new here, but maybe this can help.
If I’m wrong, they tell me.
If you type:
openssl x509 -in /etc/letsencrypt/live/ayeryhoy/fullchain.pem -noout -text | grep DNS

Return this?

Note: In my configuration, what you type here as “ayeryhoy” correspond to my domain.

Have you tried contacting email bjoern ?

Are you sure? Because the portion of the path between /live/ and /fullchain.pem would, at least normally, be a fully-qualified domain name (like, for example, www.ayeryhoy.com).

Thank you very much for your help! Already solved!
Actually the problem was that in the file “yourappname.ssl.conf” instead of putting “ayeryhoy.es” I put “ayeryhoy” without the “.es”

Thank you very much and I hope it will help if it happens to someone.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.