Forgotten certbot cron job - How clear Pending Authorizations


After changed hosting provider where I didn't have this problem (using systemd)...

Using Docker, just the time to take down my webserver container to update a certificate...
When I try to launch a certificate update by shell I receive the error "can't set attribute error".

Possible cause:
I realized to have forgotten in place the cron job of scheduled cert renew by "certbot -q renew".
Indeed my log is full of pending requests with "too many requests error" and "can't set attribute error"
From 20231214 03:44 and before with an "Address already is use" error (due to docker)

What is happend is exactly this:

  1. I took down my docker webserver container
  2. I did to update the certificate with a new subdomain of 5mode "certbot certonly --cert-name 5mode -d,,
  3. I got the error "can't set attribute" (coming as letter one)

Given: Rate Limits - Let's Encrypt

I would like to ask is it possible to clear my Pending Authorization Requests to let me work
again over my domains?
Indeed what could be the possible solutions to circumvent the limit problem arrived at the
1st gen 2024 when my certificates will start to expire if the situation gets not solved before?

And are we sure we all need this cron job automatically installed?


== Daniele Bonini

My domain is:
various, eg.

I ran this command:
submitting a "certbot certonly --cert-name -d etc."

It produced this output:
wiz# tail -n40 /var/log/letsencrypt/letsencrypt.log
orderr = self._get_order_and_authorizations(, self.config.allow_subset_of_names)
File "/usr/lib/python3/dist-packages/certbot/_internal/", line 478, in _get_order_and_authorizations
orderr = self.acme.new_order(csr_pem)
File "/usr/lib/python3/dist-packages/acme/", line 138, in new_order
response = self._post(['newOrder'], order)
File "/usr/lib/python3/dist-packages/acme/", line 338, in _post
return*args, **kwargs)
File "/usr/lib/python3/dist-packages/acme/", line 711, in post
return self._post_once(*args, **kwargs)
File "/usr/lib/python3/dist-packages/acme/", line 724, in _post_once
response = self._check_response(response, content_type=content_type)
File "/usr/lib/python3/dist-packages/acme/", line 575, in _check_response
raise messages.Error.from_json(jobj)
acme.messages.Error: urn:ietf:params:acme:error:rateLimited :: There were too many requests of a given type :: Error creating new order :: too many currently pending authorizations: 302: see Rate Limits - Let's Encrypt

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/bin/certbot", line 33, in
sys.exit(load_entry_point('certbot==2.1.0', 'console_scripts', 'certbot')())
File "/usr/lib/python3/dist-packages/certbot/", line 19, in main
return internal_main.main(cli_args)
File "/usr/lib/python3/dist-packages/certbot/_internal/", line 1733, in main
with make_displayer(config) as displayer:
File "/usr/lib/python3.11/", line 188, in exit
exc.traceback = traceback
File "/usr/lib/python3/dist-packages/josepy/", line 191, in setattr
raise AttributeError("can't set attribute")
AttributeError: can't set attribute
2023-12-14 07:36:14,791:ERROR:certbot._internal.log:An unexpected error occurred:
2023-12-14 07:36:14,793:ERROR:certbot._internal.log:AttributeError: can't set attribute

My web server is (include version):
doesn't matter, it is under docker..

The operating system my web server runs on is (include version):
Debian 11

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 2.1.0

I own an expiration window that ranges

Expiry Date: 2023-12-31 21:47:25+00:00 (VALID: 17 days)

Expiry Date: 2024-01-04 20:22:56+00:00 (VALID: 21 days)

So problem should reasonably started from December 1st.

There are some difficult ways for you to reset the pending auths.

Or, maybe try this


Thank you for the hint....


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.