Forgot to add www and now I also deleted cert


#1

My domain is:
https://greatworldwidedeals.com/
I ran this command:
certbot --apache -d greatworldwidedeals.com -d www.greatworldwidedeals.com
It produced this output:
error while running apache2ctl condigtest … apache plugin is not working etc
My web server is (include version):
apache2
The operating system my web server runs on is (include version):

Ubuntu bionic

Heres what has happened

I followed the advise to install & everything went smoothly except i did not add www
This appears to be a common problem & everyone says to use --expand but nobody explains how to

So after a few fruitless tries I decided to delete the certificate and reinstall
I followed this advise https://medium.com/@matthagemann/correct-way-to-delete-a-certbot-ssl-certificate-e8ee123e6e01

After this its where all the errors began & I was unable to run certbot --apache at this point

so then I followed this advise:

After this I ran certbot --apache -d greatworldwidedeals.com -d www.greatworldwidedeals.com

which is where I am at now with a broken certificate

Please if you want to assist please give a full command context - its confusing when people say use --expand for example this does not explain how or where to use the command

Anyway I am setting up my first VPS and it was going smoothly until this error


#2

So at this point you seem to have Apache listening on port 443 but serving HTTP instead of HTTPS.

What was the output of the last certbot command you ran? It should have recreated the greatworldwidedeals.com-le-ssl.conf file you deleted (I’m guessing at the filename), but if there was an error it might not have done so, which could explain what you’re seeing now.


#3

certbot --apache -d greatworldwidedeals.com 1 -d www.greatworldwidedeals.com

was my last command which ran without error

But now the SSL does not work

Also I deleted all conf files


#4

Maybe that’s the problem, perhaps you deleted too many files?

Can you share what your configuration looks like now? What’s in /etc/apache2/sites-enabled/ and what’s the content of those files?


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.