Deleted 2 certs, caused certbot to forget how to configure Apache


#1

I had been using certbot-auto happily on my Apache (CentOS) box for a long time. Yesterday I had two certs that were misbehaving so I deleted them:

./certbot-auto delete

This worked. However, it also seems to have killed my certbot installation. Every time I try to run it now, I get:

Error while running apachectl configtest.

WARNING: MaxClients of 300 exceeds ServerLimit value of 256 servers, lowering MaxClients to 256. To increase, please see the ServerLimit directive.
Syntax error on line 414 of /etc/httpd/conf.d/ssl.conf:
SSLCertificateFile: file '/etc/letsencrypt/live/sitename.com/cert.pem' does not exist or is empty

Certbot doesn't know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run "certbot-auto certonly" to do so. You'll need to manually configure your web server to use the resulting certificate.

And that “sitename.com” whose certificate it says is missing is NOT one of those I deleted, and the site is still working fine. Any thoughts? Can certbot be re-installed/repaired, and would that help?


#2

Hi,

This means that your certificatr file is not found…
comment out the line that refer to the files you deleted and run certbot again would resolve the problem.

It’s not an certbot problem, more of a Apache one.
Since apachectl configtest reported this error.
You deleted the file, which caused Apache vHost config can’t find the cert or other files. Then throwed this error.

Thank you


#3

I understand. I was able to fix those problems, and now certbot is working correctly again. Thanks!


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.