Focing HTTP only


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.crimecoast.com

I ran this command: Edited .htaccess to containt the following:

RewriteEngine On
RewriteCond %{HTTPS} on
RewriteRule ^ http://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

It produced this output:Too many redirects error

My web server is (include version): Apache

The operating system my web server runs on is (include version): Ubuntu 18

My hosting provider, if applicable, is: OVH VPS

I can login to a root shell on my machine (yes or no, or I don’t know):Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

EDIT:
I am trying to force HTTP only due to some scripts and fonts not being secure and causing issues for my site. Once I have corrected the issue I will force HTTPS once again.

I secured my site with let’s encrypt and removed the forllowing from my site enabled file:

RewriteEngine on
RewriteCond %{SERVER_NAME} =crimecoast.com [OR]
RewriteCond %{SERVER_NAME} =www.crimecoast.com
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

#2

Hi,

I don’t actually understand why…

However, you could try to change your site url & admin url (on Wordpress Backend, Settings > general) from HTTP to HTTPS?

Also, if you are using a drag-drop builder, you might need to change some url (manually) from http to https.

Thank you


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.