Fixing version mismatch

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot certonly -d

It produced this output: … Attempting to parse the version 0.35.0 renewal configuration file found at /etc/letsencrypt/renewal/ with version 0.31.0 of Certbot. This might not work.

My web server is (include version): nginx version: nginx/1.14.0 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 18.04.4 LTS

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

I got an email about “ACMEv1 API deprecation” … so I did an “apt-get update/upgrade” … will that fix it?

I then tried to update by licence with my newly updated certbot 0.31.0 … and got the message above about 0.35 configuration.

1 Like

Is this all the output?

try running certbot certificates and certbot renew --verbose

1 Like

hi 9peppe,

The same error appeared … followed by a stream of python debugging messages and eventually …
“certbot.errors.Error: 1 renew failure(s), 0 parse failure(s)
1 renew failure(s), 0 parse failure(s)”

The renew error is expected, because I know the renewal worked and the certificate shows up fine, I’m just worried about the version mismatch. In particular, I have the latest version of certbot from the repository, but the license appears to be well ahead of my version. Which seems weird.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.