Finding.appairing old certificates in Nginx


I have created several proxy hosts + certificate with Nginx.
I had to delete the Ngninx container and reinstall it.
After that, when I want to create the proxy hosts again with the same domain and the same redirection, I get an internal error: ["domain" is already in use].

How can I find the certificates in Ngnix or how can I delete them?

1 Like

To "find" them, try:
nginx -T | grep -i ssl_cert

Deleting them is more complicated; as you should not delete a cert while it is in use.


I'm not sure how that error is related to Let's Encrypt / certificates? Can you please elaborate?



Thank's for your quick answer!
I completely deleted the Nginx container with its data.
Then I reinstalled it from zero, then created an account and created proxy hosts.
When I go to the SSL menu to add a certificate [before deletion, it offered me "new Letsencrypt" or "existing certificates created with the different subdomains"] since the reinstallation, I only get "new Letsencrypt".
As soon as I save I get an internal error, then if I press save a 2nd time, I get the message """ is already in use. (subdomain that I had created previously.

But I also agree with your doubts, because I've created a new sub-domain and I'm getting the same error. If there really is a difference between sub-domains of the same domain...

1 Like

When I execute this command I have this answer :

[root@docker-3fec3653508f:/app]# nginx -T | grep -i ssl_cert
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

Looks like nginx isn't using any certs.
Just (re)start as if new.


Are you Nginx Proxy Manager by any chance? :thinking:


YES I use Nginx Proxy Manager

I just restarted the container, then I tried to create a new proxy hosts with a new domain, a new IP, a new port, a new mail......... ALWAYS THE SAME ERROR!

So you were right, you need to look elsewhere

@rg305 J'ai redémarrer mais toujours la même erreur.

1 Like

Our experience with NPM isn't great. In fact, many volunteers hate it. It's just terrible from what we see here on the Community.

Hopefully you can get help with what you want somewhere else on the internet.


That's not very encouraging.
But when I first installed it, everything worked fine...

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.