I deleted the certificates without realising when I deleted my docker container

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: technologylabs.online

I ran this command: docker rm mycontainer

It produced this output: the container with letsencrypt got deleted along with all certificates

My web server is (include version): NA

The operating system my web server runs on is (include version): Ubuntu 22.04

My hosting provider, if applicable, is: NA

I can login to a root shell on my machine (yes or no, or I don't know): NA

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): I was using letsencrypt docker container

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

So recreate the certificates. As long as you aren't up against a rate limit, there's no problem with doing this. But when you do, make sure they're stored outside the container so this doesn't happen again.

6 Likes

Thanks for the quick reply danb35. I had tried recreating the nginx-manager and letsencrypt containers again and issuing the certificates again, but it was failing. Let me do it again and provide the exact error details.

Thanks.

1 Like

I was able to get certificates again. The mistake I was making was that ports 80 and 443 were not used for my nginx-manager (I chose non standard ports) and few other mistakes when adding proxy host(s). Understood the issue on the documentation page.
Thanks for your help.

5 Likes