Failed authorization procedure. NXDOMAIN looking up A for www.xxxxx.org


#1

My domain is:
www.xxxx.org
I ran this command:
sudo renew
It produced this output:
Attempting to renew cert () from /etc/letsencrypt/renewal/xxxxx.org.conf produced an unexpected error: Failed authorization procedure. www.xxxx.org (tls-sni-01): urn:acme:error:dns :: DNS problem: NXDOMAIN looking up A for www.xxxxx.org. Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/xxxxx.org/fullchain.pem (failure)
My web server is (include version):
nginx
The operating system my web server runs on is (include version):
Ubuntu 16.04
My hosting provider, if applicable, is:
DigitalOcean
I can login to a root shell on my machine (yes or no, or I don’t know):
yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

If the error is above, the reason probably is that you need to enter another A record with your domain name provider’s settings.
A www 23.23.23.23. Auto


#3

Hi @tccmailer

Is this your real domain name?


#4

Obviously NOT the same domain name; thus not the real domain name.


#5

@tccmailer, you aren’t giving us much information to work with, and some of the information you are giving us is wrong (I can speculate about what command you used, but it wasn’t sudo renew). From what you’re giving us, all we can say is that it’s a DNS problem of some sort. If you want help, you’re going to need to be a lot more forthcoming with the information you’re withholding.


#6

i have already solved. the problem was that A record was missing for www.
so www was not reachable


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.