Facebook and let's encrypt


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.kornit.com

I ran this command: Debuging this page on Facebook debugger:

It produced this output:
“Can’t validate SSL Certificate. Either it is self-signed (which will cause browser warnings) or it is invalid.”

My web server is (include version): Apache 2.4.7

The operating system my web server runs on is (include version): Ubuntu 14.04 LTS

My hosting provider, if applicable, is: Kiwinet

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

However having scanned my URL here: https://www.ssllabs.com/ssltest/analyze.html?d=www.kornit.com, everything looks ok.
Could you please advise where did I go wrong?
Many thanks in advance!


Hi @Michal1

what’s that?

D:\temp>download https://www.kornit.com/ -h
SSL-Zertifikat is valide
Connection: keep-alive
X-Frame-Options: SAMEORIGIN
X-Content-Type-Options: nosniff
X-XSS-Protection: 1; mode=block
Content-Length: 178
Content-Type: text/html
Date: Tue, 23 Oct 2018 19:20:57 GMT
Location: https://www.google.com/
Server: nginx

Status: 301 MovedPermanently

509,89 milliseconds
0,51 seconds

I want to check your site - then a redirect to Google?

Hope you don’t redirect a Facebook bot to Google.

And you have some warnings, blocked mixed content.



The SSL Labs report also says that the certificate chain is incomplete.

What ACME client did you use to create the certificate?

What are the Apache settings that start with “SSLCertificate” set to?




Thank you all for your advises! Everything seems to work now properly.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.