Expired Certificate browser message, yet certbot-auto renew has run

I’ve just run
certbot-auto renew

and i have domains that are showing an out of date certificate error in edge and chrome (and i assume all browsers)

i have previously run certbot-auto renew without any problems

OS: centos 6.9
domain: portobelloroadantiques.com

when i run certbot-auto renew
i get:
Processing /etc/letsencrypt/renewal/portobelloroadantiques.com.conf
Cert not yet due for renewal

(it was due for renewal on 29th and i ran renew then) - all seemed to be ok.

Hi @JeremyS,

You have a valid certificate issued 2 days ago:

CRT ID     DOMAIN (CN)                 VALID FROM             VALID TO               EXPIRES IN  SANs
219791152  portobelloroadantiques.com  2017-Sep-28 21:18 UTC  2017-Dec-27 21:18 UTC  87 days     portobelloroadantiques.com
                                                                                                 www.portobelloroadantiques.com

certbot-auto renew says that all is ok so there is no need to renew it… did you restart/reload your apache so the new cert can be loaded?.

Cheers,
sahsanu

ah, thanks so much!!!
i hadn’t restarted apache … i’ve auto renewed many times before - always manually i don’t use a cron but i guess i’ve always done other things around the same time and done an apache restart! so i hadn’t thought to do that as this time i hadn’t.
i’m very grateful for your help. thanks again.

1 Like

ah, just to confirm, the apache restart was what was needed in this case.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.