Experience setting up Let's Encrypt on Ubunto Wordpress


#1

I just installed a new cert on my wordpress site running on Digital Ocean with ubunto with apache.

First of all, let me say: Congratulations. It was so easy! I downloaded the client with git, and ran ./letsencrypt-auto. It ran practically flawlessly.

I did run into a couple of issues that should be easy to fix:

  1. The .conf file that was generated assumed that my Document root was
    . DocumentRoot /var/www/html

When I attempted to restart my apache2 server, I got this super helpful error:
* Restarting web server apache2 AH00112: Warning: DocumentRoot [/var/www/html] does not exist

Not surprisingly, when I tried to browse to the site, I got a 500 error.

I modified the .conf file and changed the DocumentRoot it to /var/www, and restarted. That fixed it!

Is there a way that you could figure out the current DocumentRoot and use that?

  1. I got an error attempting to use the www version of my site. I fixed this by specifying the ServerName and ServerAlias in the <VirtualHost *:443> section of my conf file. Maybe this is something that the letsencrypt-auto installer could do?

  2. After it was running, I decided to redirect from easy to secure, so that all traffic would go to the SSL site. I set up this section in my conf file
    <VirtualHost *:80> ServerName example.com Redirect permanent / https://example.com/ </VirtualHost>

I then tried to re-run the letsencrypt-auto, and it worked amazingly well. This time I chose secure instead of easy.

Now ssltest.com gives me an A rating!

-ms