Error while updating email address


#1

Hello,

when I try to update my email address using ./certbot-auto register --update-registration --email <mymail> I get the error UnexpectedUpdate: RegistrationResource.
Log:

2017-01-01 20:32:13,406:DEBUG:certbot.main:Exiting abnormally:
Traceback (most recent call last):
File “/home/me/.local/share/letsencrypt/bin/letsencrypt”, line 11, in
sys.exit(main())
File “/home/me/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py”, line 776, in main
return config.func(config, plugins)
File “/home/me/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py”, line 413, in register
body=acc.regr.body.update(contact=(‘mailto:’ + config.email,))))
File “/home/me/.local/share/letsencrypt/local/lib/python2.7/site-packages/acme/client.py”, line 132, in update_registration
raise errors.UnexpectedUpdate(regr)

What can I do? I got an expiration notice to the new address already but in the regr.json I still see the old email address.


#2

Looks like you maybe forgot to specify which domain you are trying to update with the -d flag ?

try

./certbot-auto register -d yourdomain.com --update-registration --email youremail@wherever.com


#3

I sitll get the same error.


#4

I’ve never done this to be honest as I used an email address I’ve had for years when I registered all my certs. Hope someone else here can assist you.


#5

Does someone know which mail is linked with the domain v-gar.de at the moment? (perhaps @jsha) Still getting the same error… I hope it’s a client side error only.


#6

@viktor: What client version are you using? Older versions had a bug where the would crash out after receiving a successful response from the server, if the response included a change to the registration object. If that’s the situation you have, I would recommend upgrading your client to be sure.


#7

@jsha: Thanks for your reply. I’m using the latest version (I hope) of certbot and already git pulled before trying to update.

remote origin
  Fetch URL: https://github.com/letsencrypt/letsencrypt
  Push  URL: https://github.com/letsencrypt/letsencrypt
  HEAD branch: master

I think your explination applies on my problem because acme/acme/client.py line 138 causes the behavior.

if updated_regr != regr:
           raise errors.UnexpectedUpdate(regr)

But this code is still present - even in the newest version on the master branch. When and where was the bug fixed?


#8

Hm, I thought it was fixed, but it may not have actually gotten merged! I’ll take a look. Thanks for pointing it out.


#9

Im also experiencing same error messages from the same commands (both with and without specifying the domain).

A reply by @jsha here Accidentally Unsubscribed says that the crash actually happens after the email gets updated. If so, how do I check what email is registered for notifications?


#10

@jsha: are there any news yet?

I saw a pull request here already https://github.com/certbot/certbot/pull/3165/commits/4f2a8f86d888599a7bb12ece864fb9737b6e801f but my error is triggered by line 138 in Client.update_registration. This commit only fixes Client.register.


#11

I recently posted a PR against Certbot that I think should fix this issue: https://github.com/certbot/certbot/pull/4197


#12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.