Error while generating certificate


I have filled out all the details below.

I have generated certificates using this command before. Event today I was able to generate certificate for several sub domains of But it failed just for this main domain. Please let me know if any additional informaiton. Thanks in advance!

My domain is:

I ran this command: --issue -d -w /home/madhgtuj/ --server letsencrypt

It produced this output:

[madhgtuj@premium68 ~]$ --issue -d -w /home/madhgtuj/ --server letsencrypt
[Sat Mar 23 08:07:22 EDT 2024] Using CA:
[Sat Mar 23 08:07:23 EDT 2024] Single domain=''
[Sat Mar 23 08:07:24 EDT 2024] Getting webroot for domain=''
[Sat Mar 23 08:07:24 EDT 2024] Verifying:
[Sat Mar 23 08:07:25 EDT 2024] Pending, The CA is processing your order, please just wait. (1/30)
[Sat Mar 23 08:07:28 EDT 2024] Invalid status, error detail: Invalid response from 404
[Sat Mar 23 08:07:28 EDT 2024] Please check log file for more details: /home/madhgtuj/
[madhgtuj@premium68 ~]$

My web server is (include version): Apache 2.4.58

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): No (I don't think so)

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): cPanel 110.0 (build 24)

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): I am not sure what my client is

Your client appears to be But why are you using it? Doesn't cPanel have a way to get a cert?


A LiteSpeed server is responding to HTTP requests for your root domain. It also responds to HTTP and HTTPS requests for your arch and event subdomains which you recently got certs for.

The 404 is an HTTP error Not Found. It means your LiteSpeed server did not have the challenge token to return it to the Let's Encrypt server.

Usually this means the DocumentRoot in that domain name's VirtualHost (in Apache terms) did not match the -w folder value used in the command. Are you sure you used the correct path for this domain?

I don't know cPanel (or Open LiteSpeed's gui if using that) well enough to say more.


Your client appears to be But why are you using it? Doesn't cPanel have a way to get a cert?

I am not sure how to do this.

From cPanel I went to SSL/TLS > Manage SSL sites (under Install and Manage SSL for your site (HTTPS)) > Install an SSL Website > I selected my domain name and clicked on 'Autofill by Domain'. But nothing happened.

Is there some other way to do this?


1 Like

Thanks for pointing out. It started working after correcting the folder name.

I ran this command: --issue -d -w /home/madhgtuj/public_html/ --server letsencrypt


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.