Error while executing letsencrypt-auto


#1

Hello,

I want to run letsencrypt-auto but there comes the error:
IOError: [Errno 28] No space left on device You are using pip version 8.0.3, however version 8.1.2 is available. You should consider upgrading via the 'pip install --upgrade pip' command.

and a really long stacktrace.
I have pip 8.1.2 but there it shows 8.0.3.
And I have over 100GB free space!


#2

have you got space, and sufficient inodes on all devices ?

df -h
and
df -i

Should tell you about usage for space and inodes on all devices.


#3

Yes, I think there is enough space!

root@srv958:~# df -h Filesystem Size Used Avail Use% Mounted on /dev/simfs 120G 7.9G 113G 7% / devtmpfs 4.0G 0 4.0G 0% /dev tmpfs 4.0G 0 4.0G 0% /dev/shm tmpfs 4.0G 9.2M 4.0G 1% /run tmpfs 5.0M 0 5.0M 0% /run/lock tmpfs 4.0G 0 4.0G 0% /sys/fs/cgroup tmpfs 4.0G 936K 4.0G 1% /tmp none 4.0G 0 4.0G 0% /run/shm root@srv958:~# df -i Filesystem Inodes IUsed IFree IUse% Mounted on /dev/simfs 6000000 93492 5906508 2% / devtmpfs 1048576 53 1048523 1% /dev tmpfs 1048576 1 1048575 1% /dev/shm tmpfs 1048576 193 1048383 1% /run tmpfs 1048576 3 1048573 1% /run/lock tmpfs 1048576 10 1048566 1% /sys/fs/cgroup tmpfs 1048576 17 1048559 1% /tmp none 1048576 1 1048575 1% /run/shm


#4

And here is the Pip Version (if you need)

root@srv958:/opt/certbot# pip -V pip 8.1.2 from /usr/local/lib/python2.7/dist-packages (python 2.7)

I dont know whats wrong -.-


#5

Try this: https://perlgeek.de/blog-en/misc/why-is-my-tmp-directory-only-1mb.html

Today I got a really weird error on my Debian “Squeeze” Linux box – a processes tried to write a temp file, and it complained that there was No space left on device.

The weird thing is, just yesterday my root parition was full, and I had made about 7GB free space in it.

I checked, there was still plenty of room today. But behold:

$ df -h /tmp/
Filesystem            Size  Used Avail Use% Mounted on
overflow              1.0M  632K  392K  62% /tmp

So, suddenly my /tmp/ directory was a ram disc with just 1MB of space. And it didn’t show up in /etc/fstab, so I had no idea what cause it.

After googling a bit around, I found the likely reason: as a protection against low disc space, some daemon automatically “shadows” the current /tmp/ dir with a ram disc if the the root partition runs out of disc space. Sadly there’s no automatic reversion of that process once enough disc space is free again.

To remove the mount, you can say (as root)

umount -l /tmp/

And to permanently disable this feature, use

echo 'MINTMPKB=0' > /etc/default/mountoverflowtmp

#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.