Error when execute ./certbot-auto --apache certonly


#1

Hi when i’m trying to execute ./certbot-auto --apache certonly i’m getting the following error

“Installing Python packages…
Traceback (most recent call last):
File “/tmp/tmp.m7L4Ixj0pi/pipstrap.py”, line 184, in
exit(main())
File “/tmp/tmp.m7L4Ixj0pi/pipstrap.py”, line 171, in main
shell=True)
File “/opt/conda/lib/python2.7/subprocess.py”, line 219, in check_output
raise CalledProcessError(retcode, cmd, output=output)
subprocess.CalledProcessError: Command ‘pip install --no-index --no-deps -U /tmp/pipstrap-1IO98R/pip-9.0.1.tar.gz /tmp/pipstrap-1IO98R/setuptools-29.0.1.tar.gz /tmp/pipstrap-1IO98R/wheel-0.29.0.tar.gz’ returned non-zero exit status 1”

I cannot figure out how to solve this.
i am on debian 8

Thanks


#2

Hi @eric_t

what happens, if you install certbot-auto again?

wget https://dl.eff.org/certbot-auto
chmod a+x certbot-auto

#3

Hi @JuergenAuer

thanks for the reply. I have tried your solution but i’m getting the same error. I think that as a workaround i will use certbot with debian 9 where i was able to get it working. But if you have other solution please let me know i will try.

Thanks


#4

Is it possible that you have low memory or low hard drive space so that one of the subprocesses is running out of either of these resources?


#5

Hi @schoen
i don’t think this could be the problem because i have 8gb of ram and more than 20Gb on my hard drive

Thanks


#6

It looks like Conda’s Python installation is first one in your PATH. What happens if you remove it from your PATH and run certbot-auto again?