Error when Challenging


#1

I’m using the ACMESharp Quick Start guide and have hit an issue - I’m getting an error when I enter the HTTP Challenge:

PS C:\Users\Administrator.DCG> New-ACMEIdentifier -Dns managedstorage.douganconsulting.com -Alias managedstorage

IdentifierPart : ACMESharp.Messages.IdentifierPart
IdentifierType : dns
Identifier : managedstorage.douganconsulting.com
Uri : https://acme-v01.api.letsencrypt.org/acme/authz/d7KQeCX3SgxADUegoG6GieQlcFZj7i8GCXW0zdR3uUM
Status : pending
Expires : 2018-08-23 5:34:58 PM
Challenges : {, , }
Combinations : {2, 1, 0}

PS C:\Users\Administrator.DCG> Complete-ACMEChallenge managedstorage -ChallengeType http-01 -Handler iis -HandlerParameters @{ WebSiteRef = ‘Default Web Site’ }

Complete-ACMEChallenge : Invalid URI: The URI scheme is not valid.
At line:1 char:1

  • Complete-ACMEChallenge managedstorage -ChallengeType http-01 -Handler …
  •   + CategoryInfo          : NotSpecified: (:) [Complete-ACMEChallenge], UriFormatException
      + FullyQualifiedErrorId : System.UriFormatException,ACMESharp.POSH.CompleteChallenge
    
    

I don’t understand the error - I have followed the steps in the guide, but am clearly missing something. Can anyone shed light on where I’ve gone wrong?

Thanks,

Des


#2

“managedstorage” might need to be the FQDN (“managedstorage.douganconsulting.com”)


#3

I tried that, too, thinking it might need it, but it did not like that either.

I tried the manual DNS method and added a TXT record to my DNS; it is still pending after about 3 hours when I check the Update-ACMEIdentifier command.

Thanks,

Des


#4

Out of curiosity, what provider hosts your DNS? You may not have to use the manual method if your provider is in this list and are willing to give a different client a try.


#5

My DNS provider is CIRA (the Canadian Internet authority - they have a managed DNS service I use).

I did try the manual DNS method; it’s been in pending status for 24 hours now, so there is clearly something wrong. Can I flush the request and re-do it?

Or, if there is another client you would recommend, I’m happy to try it.

Thanks,

Des


#6

An authz remains pending until you run the command to make it go (or it expires, which currently happens after one week).

I don’t know anything about ACMESharp, but skimming the quick start, it looks like that’s the step after “Complete-ACMEChallenge”, which is where you got stuck…

Still, there’s probably nothing wrong on Let’s Encrypt’s end.


#7

Matt,

Thanks - It was something I’d done (or not, as the case may be) - I misread a step.

Thanks for the push.

Des


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.