ACMEChallenge - manual handler works, iis handler fails


#1

Please fill out the fields below so we can help you better.

My domain is: e-sol.org.uk

I ran this command:Complete-ACMEChallenge autodiscover.e-sol.org.uk -ChallengeType http-01 -Handler iis -HandlerParameters @{ WebSiteRef = ‘Default Web Site’ } | select Identifier, status, Expires

It produced this output:
Complete-ACMEChallenge : The given key was not present in the dictionary.
At line:1 char:1

  • Complete-ACMEChallenge autodiscover.e-sol.org.uk -ChallengeType http-01 -Handler …
  •   + CategoryInfo          : NotSpecified: (:) [Complete-ACMEChallenge], KeyNotFoundException
      + FullyQualifiedErrorId : System.Collections.Generic.KeyNotFoundException,ACMESharp.POSH.CompleteChallenge
    
    

My operating system is (include version): 2008 R2

My web server is (include version): IIS 7.5

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#2

hi @rf_at_e-sol

have a look at the docs https://github.com/ebekker/ACMESharp/wiki/Example-Usage

acmesharp works on a concept of a vault which contains keys, certs and csrs

A) have you initialised the vault
B) have you generated an RSA Key (to authenticate against letsencrypt)
C) have you generate a web RSA key and CSR

Andrei


#3

Thanks for the reply. I’ve followed the doc you linked to.

When I get to the command:
Get-ACMEChallengeHandlerProfile -ListChallengeHandlers

I only get manual, which is obviously why the iis handler request fails :slight_smile:

Any idea how I install ACMESharp.Providers.IIS (and where I get the files from for it) so that iis is listed as an available handler?


#4

hi @rf_at_e-sol

should be part of the bundle

how did you build this?


#5

Thanks for the reply.

I downloaded it from here - http://www.netometer.com/downloads/ACME-Exchange.zip

I’ve also tried downloading and installing this https://github.com/ebekker/ACMESharp/releases/download/v0.8.1.0-EA/ACME-posh.zip

And I’ve tried install-package ACMESharp

but still the only handler available is manual

Any help is greatly appreciated.

Thanks

Rob


#6

BUMP…
Anyone have an idea how I can add other handlers?


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.