Error on SSL Renewal

Auto renewal for our website stopped working and is not even working when done manually. Any suggestions? We have tried to open up the firewall to the servers router location but still not passing challenges.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot-auto --apache -d

It produced this output:

  • The following errors were reported by the server:

    Type: connection
    Detail: Fetching
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version):

Ubuntu 14.04

I can login to a root shell on my machine (yes or no, or I don’t know):


The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

certbot 0.28.0

1 Like


Is there a firewall/IPS/Geo-Location blocking HTTP access?

1 Like

Hello RG,
Yes we are using Meraki Firewalls and have blocked specific countries like Russia, China, North Korea, UK
I have the forwarding rules already set as wide open in an attempt to establish a connection.

1 Like

If you can’t time trigger the allows to match your challenge requests (highly likely), you might consider always allowing HTTP (from all IPs) and providing a simple responder to forward all requests to HTTPS (which can then be Geo-Location blocked) while excluding the challenge requests from the forwarding.

[Maybe all that should have been like 4 sentences - if you have any questions, just ask]


Hi RG,
Thanks for the update. I called Meraki and tried to verify that the specific ports we need are opened to establish connection. I’m very new “LetsEncrypt” SSL installations. Is there a command I use to renew the existing config? Or do we need to start from scratch?

I used command…
sudo /usr/local/bin/certbot-auto certonly --apache
and received …
Error creating new order :: too many failed authorizations recently: see
after a few attempts at changing ports on the firewall.

Not even sure which GoDaddy TXT is currently being used or if the existing was updated, is there a way to check?
Any suggestions is greatly appreciated. Thanks!

I got a reply from Meraki saying all i need to do is upload a new cert. Is there a way I can check the existing cert TXT? to compare to my TXT records to Godaddy?

The too many failed authorizations usually timeout after one hour.
You should be able try again now.

Thanks RG,
I was able to solve the issue…
Looks like there are some servers on the “lets encrypt” side that wasn’t resolving with Meraki…
I had to temporarily allow ALL traffic for the sake of getting the cert installed. I was able to immediately establish connection and install the cert afterward.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.