Error in checking parameter list: Apache 2.4.53 - CentOS 9 Stream

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: NA

I ran this command: certbot --apache

It produced this output:

2022-09-13 07:39:08,088:DEBUG:certbot._internal.main:certbot version: 1.29.0
2022-09-13 07:39:08,088:DEBUG:certbot._internal.main:Location of certbot entry point: /usr/bin/certbot
2022-09-13 07:39:08,088:DEBUG:certbot._internal.main:Arguments: ['--apache']
2022-09-13 07:39:08,089:DEBUG:certbot._internal.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#apache,PluginEntryPoint#manual,PluginEntryPoint#null,PluginEntryPoint#standalone,PluginEntryPoint#webroot)
2022-09-13 07:39:08,104:DEBUG:certbot._internal.log:Root logging level set at 30
2022-09-13 07:39:08,105:DEBUG:certbot._internal.plugins.selection:Requested authenticator apache and installer apache
2022-09-13 07:39:08,244:DEBUG:certbot_apache._internal.configurator:Apache version is 2.4.53
2022-09-13 07:39:08,267:WARNING:certbot_apache._internal.apache_util:Error in checking parameter list:
2022-09-13 07:39:08,267:DEBUG:certbot._internal.plugins.disco:Misconfigured PluginEntryPoint#apache: Apache is unable to check whether or not the module is loaded because Apache is misconfigured.
Traceback (most recent call last):
File "/usr/lib/python3.9/site-packages/certbot/_internal/plugins/", line 160, in prepare
File "/usr/lib/python3.9/site-packages/certbot_apache/_internal/", line 368, in prepare
self.parser = self.get_parser()
File "/usr/lib/python3.9/site-packages/certbot_apache/_internal/", line 79, in get_parser
return CentOSParser(
File "/usr/lib/python3.9/site-packages/certbot_apache/_internal/", line 164, in init
super().init(args, **kwargs)
File "/usr/lib/python3.9/site-packages/certbot_apache/_internal/", line 79, in init
File "/usr/lib/python3.9/site-packages/certbot_apache/_internal/", line 169, in update_runtime_variables
File "/usr/lib/python3.9/site-packages/certbot_apache/_internal/", line 299, in update_runtime_variables
File "/usr/lib/python3.9/site-packages/certbot_apache/_internal/", line 305, in update_defines
self.variables = apache_util.parse_defines(self.configurator.options.ctl)
File "/usr/lib/python3.9/site-packages/certbot_apache/_internal/", line 153, in parse_defines
matches = parse_from_subprocess(define_cmd, r"Define: ([^ \n]
File "/usr/lib/python3.9/site-packages/certbot_apache/_internal/", line 208, in parse_from_subprocess
stdout = _get_runtime_cfg(command)
File "/usr/lib/python3.9/site-packages/certbot_apache/_internal/", line 241, in _get_runtime_cfg
raise errors.MisconfigurationError(
certbot.errors.MisconfigurationError: Apache is unable to check whether or not the module is loaded because Apache is misconfigured.
2022-09-13 07:39:08,269:DEBUG:certbot._internal.plugins.selection:Single candidate plugin: * apache
Description: Apache Web Server plugin
Interfaces: Installer, Authenticator, Plugin
Entry point: apache = certbot_apache._internal.entrypoint:ENTRYPOINT
Initialized: <certbot_apache._internal.override_centos.CentOSConfigurator object at 0x7f4ee22512b0>
Prep: Apache is unable to check whether or not the module is loaded because Apache is misconfigured.

My web server is (include version): Apache 2.4.53 (CentOS Stream)

The operating system my web server runs on is (include version): CentOS Stream release 9

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.29.0

Welcome to the community @csumner

Can you show result of this

apachectl configtest

or this if that does not work
httpd -t

Configuration is fine according to apachectl.

[root@aluminum ittrium]# apachectl configtest
Syntax OK

Something changed from CentOS 8 to CentOS 9
For the time being, (if possible) I would switch to using the --webroot authenticator and manual web server configurations (when needed).


This is a known problem with Certbot and RHEL/Centos9. It runs the wrong command to interact with Apache on that platform. This issue is being tracked here:


But, the apachectl configtest command worked from command prompt. Perhaps I misunderstand the underlying.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.