"Error getting validation data"

My domain is: racknet.noip.me

I ran this command: sudo certbot --apache

It produced this output:

rackover@rackover-CHADNET:~/APACHE2/gameservices⟫ sudo certbot --apache
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache

Which names would you like to activate HTTPS for?


1: racknet.noip.me


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter ‘c’ to cancel): 1
Cert is due for renewal, auto-renewing…
Renewing an existing certificate
Performing the following challenges:
tls-sni-01 challenge for racknet.noip.me
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. racknet.noip.me (tls-sni-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Error getting validation data

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: racknet.noip.me
    Type: connection
    Detail: Error getting validation data

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

The operating system my web server runs on is (include version):

Distributor ID: Ubuntu
Description: Ubuntu 16.04.5 LTS
Release: 16.04
Codename: xenial

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

Hi @Rackover

the tls-sni-01 - validation is deprecated, support ends 2019-02-13.

So you should change your validation method.

Try

sudo certbot --apache --preferred-challenges http

Hi, thanks for your reply.
It does not work neither, but at least the error is different.

1 rackover@rackover-CHADNET:/etc/apache2⟫ sudo certbot --apache --preferred-challenges http
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache

Which names would you like to activate HTTPS for?


1: racknet.noip.me


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter ‘c’ to cancel): 1
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for racknet.noip.me
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. racknet.noip.me (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://racknet.noip.me/.well-known/acme-challenge/d_Wo10oO_5A8Iw3oXaVlxDBojZcsBtFMTGMie9YnTDM: “\n\n404 Not Found\n\n

Not Found

\n<p”

IMPORTANT NOTES:

Your main configuration


Domainname Http-Status redirect Sec. G
http://racknet.noip.me/
78.224.198.110 302 http://racknet.noip.me/portal.php 0.163 D
http://racknet.noip.me/portal.php 200 4.294 H
https://racknet.noip.me/
78.224.198.110 -14 10.023 T
Timeout - The operation has timed out
http://racknet.noip.me/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
78.224.198.110 404 0.147 A
Not Found

looks ok. So you have redirects.

Check your apache config to find your webroot / DocumentRoot.

Then create a file (file name 1234) in /yourwebroot/.well-known/acme-challenge and try to load this file via

http://racknet.noip.me/.well-known/acme-challenge/1234

If this works, you have your correct webroot. So use

certbot run -a webroot -i apache -w yourWebRoot -d yourdomain.com
1 Like

Thank you, it works :slight_smile:

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.