Error: Expected no more than 3 tokens for --infobox, have 15


#1

My domain is: staging.genius-skills.co.za

I ran this command: certbot-auto certonly --manual -d staging.genius-skills.co.za

It produced this output:
An unexpected error occurred:
dialog-like terminated due to an error: the dialog-like program exited with status 3 (which was passed to it as the DIALOG_ERROR environment variable). Sometimes, the reason is simply that dialog was given a height or width parameter that is too big for the terminal in use. Its output, with leading and trailing whitespace stripped, was:

Error: Expected no more than 3 tokens for --infobox, have 15.
Use --help to list options.Please see the logfiles in /var/log/letsencrypt for more details.

Contents of logfile…
joe@joe-desktop:~/workspace/genius$ sudo tail -n 48 /var/log/letsencrypt/letsencrypt.log

2016-11-28 21:38:44,915:DEBUG:certbot.error_handler:Calling registered functions
2016-11-28 21:38:44,924:DEBUG:certbot.main:Exiting abnormally:
Traceback (most recent call last):
File “/home/joe/.local/share/letsencrypt/bin/letsencrypt”, line 11, in
sys.exit(main())
File “/home/joe/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py”, line 776, in main
return config.func(config, plugins)
File “/home/joe/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py”, line 563, in obtain_cert
action, _ = _auth_from_domains(le_client, config, domains, lineage)
File “/home/joe/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py”, line 100, in _auth_from_domains
lineage = le_client.obtain_and_enroll_certificate(domains)
File “/home/joe/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/client.py”, line 281, in obtain_and_enroll_certificate
certr, chain, key, _ = self.obtain_certificate(domains)
File “/home/joe/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/client.py”, line 253, in obtain_certificate
self.config.allow_subset_of_names)
File “/home/joe/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/auth_handler.py”, line 74, in get_authorizations
resp = self._solve_challenges()
File “/home/joe/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/auth_handler.py”, line 116, in _solve_challenges
raise
File “/home/joe/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/error_handler.py”, line 81, in exit
self._call_registered()
File “/home/joe/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/error_handler.py”, line 101, in _call_registered
logger.error(“Encountered exception during recovery”)
File “/usr/lib/python2.7/logging/init.py”, line 1193, in error
self._log(ERROR, msg, args, **kwargs)
File “/usr/lib/python2.7/logging/init.py”, line 1286, in _log
self.handle(record)
File “/usr/lib/python2.7/logging/init.py”, line 1296, in handle
self.callHandlers(record)
File “/usr/lib/python2.7/logging/init.py”, line 1336, in callHandlers
hdlr.handle(record)
File “/usr/lib/python2.7/logging/init.py”, line 759, in handle
self.emit(record)
File “/home/joe/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/log.py”, line 64, in emit
self.width + self.PADDING_WIDTH)
File “/home/joe/.local/share/letsencrypt/local/lib/python2.7/site-packages/dialog.py”, line 2675, in infobox
kwargs)
File “/home/joe/.local/share/letsencrypt/local/lib/python2.7/site-packages/dialog.py”, line 1760, in _widget_with_no_output
code, output = self._perform(args, **kwargs)
File “/home/joe/.local/share/letsencrypt/local/lib/python2.7/site-packages/dialog.py”, line 1541, in _perform
args_file)
File “/home/joe/.local/share/letsencrypt/local/lib/python2.7/site-packages/dialog.py”, line 1502, in _handle_program_exit
child_output_rfd)
File “/home/joe/.local/share/letsencrypt/local/lib/python2.7/site-packages/dialog.py”, line 1454, in _wait_for_program_termination
child_output.strip()))
DialogError

My operating system is (include version):
joe@joe-desktop:~/workspace/genius$ lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 16.10
Release: 16.10
Codename: yakkety

My web server is (include version):
I have a Java application built using Dropwizard (http://www.dropwizard.io/). It is packaged as an executable jar that has an embedded Jetty webserver (http://www.eclipse.org/jetty/)

My hosting provider, if applicable, is:
Heroku

I can login to a root shell on my machine (yes or no, or I don’t know):
I’m running in manual mode, which means that I don’t need to access the heroku server

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
No


An unexpected error occurred: DialogError
#2

I’m not sure what exactly is causing this, but you can avoid any dialog-related issues by adding the -t flag to your command line, i.e. ./certbot-auto certonly --manual -d staging.genius-skills.co.za -t. This will launch certbot in text-only mode.


#3

Awesome, thanks for the tip! I’ll give it a go…


#4

That worked a treat. Thanks Patrick!


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.