Error creating certificate in Nginx Proxy Manager [Solved]

I'm trying to create a certificate using NPM (Nginx Proxy Manager), version 2.9.1, I managed to create it 2 days ago and now it's giving an error. The same thing happened with a friend.

Oracle server running Ubuntu 20.04
Ports 80 and 443 are open, DNS responding normally.

Here you can have more information about the error log:

The domain I tried to create is dns.t4l35.host and d1.t4l35.host (for testing)

Hello @talesam,

Did you try to issue the certificate again? I'm asking because around the time you tried to issue the certificate there was an incident related to Let's Encrypt API

Cheers,
sahsanu

Hello, I tried to do it about 15 minutes ago and my friend also in his cervidor and the same error.

So you are still receiving the same internal error?

2021-10-17 03:30:02,664:DEBUG:acme.client:Received response:
HTTP 500
Server: nginx
Date: Sun, 17 Oct 2021 03:30:02 GMT
Content-Type: application/problem+json
Content-Length: 116
Connection: keep-alive
Boulder-Requester: 236307560
Cache-Control: public, max-age=0, no-cache
Link: <https://acme-v02.api.letsencrypt.org/directory>;rel="index"
Replay-Nonce: 0001vt83m1y7AG3kg64E8-epcogpMvrutofEfmOlcqnRg2Y

{
  "type": "urn:ietf:params:acme:error:serverInternal",
  "detail": "Unable to update challenge",
  "status": 500
}
1 Like

@talesam Two things. At github you were asking about rate limits. If you reach those you will get an appropriate error message - not an http 500. I looked at your cert history and do not see any problem with rate limit.
https://crt.sh/?Identity=t4l35.host&deduplicate=Y

Also, right now I cannot reach your server on port 80. This would cause a different error when trying to issue or renew your LE cert.

curl -I  dns.t4l35.host

HTTP/1.1 502 Bad Gateway
Server: openresty
Date: Sun, 17 Oct 2021 16:45:43 GMT
Content-Type: text/html
Content-Length: 154
Connection: keep-alive

I cannot explain your original http 500 error. That looks like a fault with the LE servers - usually those are temporary.

it looks like it was a glitch in the LE servers, I just created the certificate now, thanks.

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.