Error connecting to service: acme: error fetching response: Get dial tcp4: lookup - server misbehaving

Why like this? even though there was no error before

That IP address is a Contabo GmbH, Germany IP address. Let's Encrypt uses Cloudflare for its DNS hosting. So to me that indicates the DNS servers used by your hosting provider is defunct and should be fixed. Please file an issue with your hosting provider regarding this issue.

No error at Let's Encrypts side as far as I can see.


We own the VPS. Why doesn't such a thing happen in PLESK Panel? that warning error in WHM or cPanel

How to fix it? please help :cry:

This is not a Let's Encrypt related error but a DNS lookup error. Not something we can fix for you. You should probably use/configure a different, properly working DNS server on your VPS.


Why this url -> it's no problem?

Okay thank your buddy, we will try with cloudflare for DNS

I don't know, I'm not the system operator of the dysfunctional DNS server.

As you can see here: | DNSViz there's nothing wrong with the Let's Encrypt API DNS.


this succesfull for another domain,

this error when I try reinstall plugin

(…) which is ALSO a non-Let's Encrypt-related DNS lookup error, but now for the hostname

Which only strengthens my idea that this is a Contabo DNS server issue. Please file an issue with Contabo regarding your DNS trouble(s).


If you have root access, then go to WHM→Resolver Configuration and set some different DNS resolvers. May I suggest:,,,

Osiris is correct about why you are experiencing issues. It's a problem with the chosen resolvers on your VPS.


Yess we have root access,

Okay, I will try it.. wait a time for fix it :pray::pray:

what I fill?

You fill whatever IP addresses for DNS servers you want to use. If you don't know, ask in an appropriate support channel for your system--which isn't here. Your issues have nothing to do with Let's Encrypt.


this my DNS IP

I'm sorry, but I'm closing this thread, as the issue at hand has nothing to do directly with Let's Encrypt or TLS for that matter.

This has been said a few times already and @_az literally has handed out a few options for you. If you're still unable to fix this, please contact the appropriate channel of the provider of your VPS.