Could not obtain directory: cURL error 6: Could not resolve host: acme-v02.api.letsencrypt.org; Unknown error

Hello,
im using Plesk Obsidian 18.0.29 Update1 / Centos 7 and try to request for my plesk panel an LetsEncrypt Certificate. When requesting the Cert i get the error message:

Error: Could not issue a Let’s Encrypt SSL/TLS certificate for XYZ .stratoserver.net .

Failed to connect to the Let’s Encrypt server https://acme-v02.api.letsencrypt.org .
Please try again later or report the issue to support.
Details

Could not obtain directory: cURL error 6: Could not resolve host: acme-v02.api.letsencrypt.org; Unknown error (see https://curl.haxx.se/libcurl/c/libcurl-errors.html)

Any Idea how to solve this?
Thank You!

1 Like

Hi @Salli

your machine has a wrong / missing dns / network configuration.

So it’s impossible to find the ip address of the api endpoint.

1 Like

Hello Juergen,

thanks for the information. Strange, Resolving Servers Hostname via IP / Name Public works perfect, what else could be the issue?

Im using Let’s Encrypt Extension from Webcataloge Version 2.11.1-640

Best regards
Salli

1 Like

Testing nslookup from the server:

nslookup acme-v02.api.letsencrypt.org
Server: 127.0.0.1
Address: 127.0.0.1#53

Non-authoritative answer:
acme-v02.api.letsencrypt.org canonical name = prod.api.letsencrypt.org.
prod.api.letsencrypt.org canonical name = ca80a1adb12a4fbdac5ffcbc944e9a61.pacloudflare.com.
Name: ca80a1adb12a4fbdac5ffcbc944e9a61.pacloudflare.com
Address: 172.65.x.x
Name: ca80a1adb12a4fbdac5ffcbc944e9a61.pacloudflare.com
Address: 2606:4700:60:0:f53d:5624:85c7:3a2c

You should probably try again, it could have been a transient issue.

Tried yet again, same error when requesting the Cert

If you use Plesk and if Plesk can’t connect Letsencrypt, then ask your hoster.

Then your Plesk configuration doesn’t work. But that’s a Plesk / server internal problem.

Plesk can connect as the requests for the Domains work without any issue. But the Admin Panel request for the Host Name still fail…

And that’s the problem. Or you have an internal misconfiguration. Or the Admin panel uses another name server (not your working manual nslookup).

The Domains are managed as well by the Admin Panel, so the Panel dont use a own or different name server. And the lookup for the API Endpoint from the Server works as I send above. Is there anything else what I could test ?
Thx

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.