Error: CAA record for kodementor.com prevents issuance


#1

My domain is:

I ran this command:
I followed the article at this linked. As described in article, I navigate to https://www.sslforfree.com/ and followed the steps.

I selected manual verification aster entering my domain name. It gave me two downloadable file and I uploaded them in the directory specified ( 1. http://kodementor.com/.well-known/acme-challenge/wUoY3wHdR8vjBrJ…). Both files.

Then, when I finally click on the “Download SSL Certificate” button, I get the error.

It produced this output:

Domain “kodementor.com” challenge3 failed. Response from “https://acme-v02.api.letsencrypt.org/acme/challenge/JszdS0iorjGzYniKPyxRaGe-wYx8RYjTqCJgHUTG0BM/11216929622” was:

Warning: Your verification URL is not returning the correct contents to our verification servers. The URL looks like it is blocking bots and which inadvertently blocks our servers from receiving the correct content. Contact your host, a professional developer or admin for further help with fixing it.

Error: CAA record for kodementor.com prevents issuance

Full Error: { “type”: “http-01”, “status”: “invalid”, “error”: { “type”: “urn:ietf:params:acme:error:caa”, “detail”: “CAA record for kodementor.com prevents issuance”, “status”: 403 }, “url”: “https://acme-v02.api.letsencrypt.org/acme/challenge/JszdS0iorjGzYniKPyxRaGe-wYx8RYjTqCJgHUTG0BM/11216929622”, “token”: “QT2eI0HG2n-ZpWlKTXXTeo244RvQnMnbRe5rKsIKJ1k”, “validationRecord”: [ { “url”: “http://kodementor.com/.well-known/acme-challenge/QT2eI0HG2n-ZpWlKTXXTeo244RvQnMnbRe5rKsIKJ1k”, “hostname”: “kodementor.com”, “port”: “80”, “addressesResolved”: [ “207.180.212.7” ], “addressUsed”: “207.180.212.7” } ] }
My web server is (include version):

The operating system details:

System Linux server2.himalayan.host 3.10.0-962.3.2.lve1.5.24.5.el7.x86_64 #1 SMP Thu Nov 22 09:42:49 EST 2018 x86_64

PHP Version 7.2.13

My hosting provider, if applicable, is:
http://himalayanhost.com

I cannot login to a root shell on my machine

I’m using a control panel to manage my site. cPanel Version 76.0 (build 15)


#2

Yes, you have this CAA record:

kodementor.com.         14400   IN      CAA     0 issue "comodoca.com"

You need to add 0 issue "letsencrypt.org" – or remove the record entirely – to allow Let’s Encrypt to issue certificates for the domain.

Where do you manage DNS?

And, since you’re using cPanel, can you use cPanel to automatically obtain and renew an SSL certificate? Using SSL For Free every couple months is a hassle.

Edit: You already have certificates issued by cPanel:

https://crt.sh/?q=%kodementor.com


#3

As pointed out, cPanel AutoSSL already created and installed a certificate for you - https://www.kodementor.com/ .

To fix the “not secure” message, you’ll need to fix up your mixed content: https://www.whynopadlock.com/ . Changing to Let’s Encrypt won’t help with that.

For the record (but doesn’t matter to you and you can ignore it):

Your nameservers are hosted by cPanel DNSONLY, so you should be able to get into the “DNS Advanced Zone Editor” in your cPanel user interface to add a CAA record as suggested above.

However, on some hosts the advanced zone editor is disabled, so in that case you would need to contact your webhost to ask them to do it.


#4

Can you please explain where to add letsencrypt.org instead of comodoca.com. I am sorry, I am just new to these kinds of stuff. Hope you understand

DNS Advanced Zone Editor is disabled on my cpanel


#5

Why do you need a Let’s Encrypt certificate? https://kodementor.com/ already has a certificate.


#6

Yes, I can navigate to the https://kodementor.com but when I click on https information, it shows not fully secure unlike others.


#7

Hi @kodementor

but this isn’t a problem of your certificate. You have a proper working cPanel-certificate.

CN=kodementor.com
	30.10.2018
	29.01.2019
	kodementor.com, autodiscover.kodementor.com, 
cpanel.kodementor.com, mail.kodementor.com, 
webdisk.kodementor.com, webmail.kodementor.com, 
www.kodementor.com - 7 entries

It’s only a problem of your website. You have mixed content (content loaded via http, not https).

Use FireFox or Chrome, then Ctrl + Shift + I, then open the console. There you see some wrong links:

http://www.kodementor.com/wp-content/uploads/2018/03/kodementor-logo-300x120.png
http://www.kodementor.com/wp-content/uploads/2018/09/new-logo.jpg

All links must be changed to https - links.

PS: It’s Wordpress, perhaps there is a global setting to change that.


#8

Thank You everyone for your replies. Finally, I managed to convert http to https. Thank you