Error authorization using http-01 validation

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: sd.iteam-samara.ru

I ran this command: win-acme

It produced this output:

My web server is (include version): nginx

The operating system my web server runs on is (include version): Windows 8.1

My hosting provider, if applicable, is: allhostings

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

I have get error 403
Preliminary validation failed the server answered “null”.

1 Like

Hi,

If you are running win-acme, what’s the version for that?
Also, what’s the full output by win-acme?

Thank you

1 Like

Hello,
I am using win-acme ver. 2.1.6.773 (x64, Releasepluggable).
Output win-acme:

Cached order available but not used with the --force switch.
First chance error calling into ACME server, retrying with new nonce…
Authorize identifier www.sd.iteam-samara.ru
Authorizing www.sd.iteam-samara.ru using http-01 validation (FileSystem)
Answer should now be browsable at http://www.sd.iteam-samara.ru/.well-known/acm
e-challenge/DGjbOrFhmv043GHULFRt7QpSLSQqS0Gs4EOirbn9zgk
Preliminary validation failed, the server answered ‘(null)’ instead of 'DGjbOrF
hmv043GHULFRt7QpSLSQqS0Gs4EOirbn9zgk.VRe1zfVp9BNlfKOACzekRYrAItkQbn7-Zy-CMJgrsJQ
'. The ACME server might have a different perspective
{
“type”: “urn:ietf:params:acme:error:unauthorized”,
“detail”: "Invalid response from http://www.sd.iteam-samara.ru/.well-known/acm
e-challenge/DGjbOrFhmv043GHULFRt7QpSLSQqS0Gs4EOirbn9zgk[my ip]: "<html

\r\n 404 Not Found\r\n\r\n<> 40
4 Not Found\r\n


nginx\r\n"",
“status”: 403
}
Authorization result: invalid
1 Like

Log nginx by the same time:

2020/04/12 14:19:44 [error] 1172#1160: *5 CreateFile() “C:\nginx/html/.well-known/acme-challenge/DGjbOrFhmv043GHULFRt7QpSLSQqS0Gs4EOirbn9zgk” failed (3: The system cannot find the path specified), client: 66.133.109.36, server: sd.iteam-samara.ru, request: “GET /.well-known/acme-challenge/DGjbOrFhmv043GHULFRt7QpSLSQqS0Gs4EOirbn9zgk HTTP/1.1”, host: “www.sd.iteam-samara.ru

1 Like

So what I’m guessing is that your win-acme might have an incorrect configuration or something similar, which didn’t set the right Nginx path when writing files.

What did you input when you request your certificate?

Thank you

1 Like

Thank you very much.
I mistake in the right Nginx path (folder .well-known).
Problem is solved. SSL certificate has been issued and installed to Nginx.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.