ECDSA certificate not NIST/HIPAA compliant?

I have been running the tests on my server, which has a P-384 ECDSA certificate alongside a 4096-bit traditional RSA certificate, on nginx 1.11.x. It states that “The ECDSA certificate provided has not been signed using the proper algorithm according to NIST guidelines.” with a similar message for the new HIPAA test.
Is this because my EC certificate is 384 rather than 256 bits, or because it is signed against a RSA intermediate, or is it a bug in the tests?
When I remove the EC certificate and let the test see only the RSA-4096 certificate, the test passes fine and displays compliant with PCI-DSS, HIPAA, and NIST, instead of only PCI-DSS. The domain I tested uses SNI, but the same behavior occurs with my main, non-SNI domain.

I've seen things like that in the past (with RSA key size and TLS versions) but I'd need the NIST guidelines in question.

Well it was with the above test too.

Hi BFeely

Most likely reason is your TLS cipher selection.

The cert and key are within NIST Guidelines.

Below are the Ciphers I have enabled on my server got get PCI-DSS compliance.


You can use this tool to generate a NGINX config for you:

The NIST Publication HTBridge Tests against can be found here:

You can also run a test with

As mentioned, it was only my certificate that prevented the HTBridge test from marking as HIPAA or NIST. All other points in the same test came up green, and it came up all green on the PCI-DSS test, and gave an A+ rating.
The SSL Labs test gives an A+ rating too.

EDIT 12/10: It appears that HTBridge does not certify EC certificates that are signed against a RSA intermediate.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.